Saab Link Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
3,920 Posts
Discussion Starter · #1 ·
so i left work started fine...went to the market, lights off, evrything normal...wont start....get a jump run it for almost 30 min...go to friends park...wont start...jump come home sleep....in the morning i check all my stereo wires and evrything looks clean and connecting...well not clean but no breaks anywhere...wont start.....but my alarm still works and interior lights...does the battery just not have enough umph anymore? i think ill try a swap see what happens..... kinda not cool!! and ideas would help thanks! im going to look behind the dash tomarro...
 

·
HNNLIC
Joined
·
4,209 Posts
iwantaviggen said:
car on 14.2 V
This means your alternator is fine. The voltage when the car is on is your alt. voltage since your battery is not being used, but is acutually being charged. That is around the normal voltage your alternator should be putting out.

car off 12.8 V
This is checking the part of your battery that your accessories use.... and doesn't have anything to do with your CCA (Cold Cranking Amps). Your cranking power is whats needs to be checked in this case since your car won't start.

If this voltage were low, then the cranking power of your battery would be low as well, however not necessarily vise versa.

Some places can recharge the battery cranking power, however usually this doesn't work and its best just to replace the battery.

Just fyi of course ;)
 

·
Registered
Joined
·
3,920 Posts
Discussion Starter · #7 ·
thanks for all that info...yeah i heard that if it drops bellow 9 than its bad...so when i got a 4 i figured it was the battery going out...getting a redtop for cheap i hope
 

·
Registered
Joined
·
274 Posts
OOOOooo redtops are nice. I put one in my 9000. Glad to hear its not the alternator... enjoy your new battery. They sell em at costco if theres one nearby, thats where I got mine. It was 90$
 

·
Registered
Joined
·
3,920 Posts
Discussion Starter · #9 ·
thanks for the tip...but a friend is trying to hook me up at his 4wheel shop
 

·
Registered
Joined
·
3,920 Posts
Discussion Starter · #10 ·
redtop wouldnt fit...dont want to spend time extending cables and shit..... got a diehard.....man i like those movies!! haha
 

·
Registered
Joined
·
546 Posts
iwantaviggen said:
redtop wouldnt fit...dont want to spend time extending cables and shit
The Redtop needs to be installed backwards so the cables reach.
 

·
Registered
Joined
·
3,920 Posts
Discussion Starter · #12 ·
yeah but my power cable will not reach at all!...i tried using my brothers....because the terminals are in the middle....thanks tho..
 

·
Registered
Joined
·
745 Posts
You might want to get your money back...because your problem may be something ridiculously simple, but overlooked. Sounds indicative of your having gone to the market, and possibly turning the trunk light on while putting something in.

I had a similar problem....the car was starting slow for some reason. I located the trunk light switch left on in the trunk while I was cleaning it one day...after about an 8 mile drive, she recharged, and back to normal.

just a thought..
 

·
Registered
Joined
·
51 Posts
Four years plus or minus one is about it for battery life.
12.8 when "car off" is good, but is misleading.
4 during starting is horrible - I recall 9 using a good battery
Saab should use an "intelligent" voltmeter tied in with the SID.
Even an engine bay voltmeter would be better than nothing.
 

·
Registered
Joined
·
3,920 Posts
Discussion Starter · #15 ·
yeah 9 is the lowest it should go....

well my turbo timer that i have yet to install has a battery meeter on it...wich woulda been nice but will come in handy later....
 

·
Registered
Joined
·
51 Posts
Please tell us about the turbo timer and the battery meter, Viggen
 
1 - 16 of 16 Posts
Top