Saab Link Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
I got some HID for my 01 Viggen and i have the all hocked up and they worked for a bit but now i have the front light failure thing on and one keeps blowing the fuse for the L/F head light. Any ideas? i have done HIDs befor but this car has me stumped :(
 

·
Registered
Joined
·
3,061 Posts
there is a pin on the orange light controll relay that you can cut. Search saabkids hid thread and your answer is somewhere in there.
 

·
Registered
Joined
·
1,487 Posts
i don't think that really is the reason it's tripping the relays or blowing fuses though. if i recall that pin trick only stops the signal to the SID. i've run hid's on three og93's with little problem. which hid's are you running and what watt are they?

The bastard beat me to it...
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #6 ·
well that what i thought i went to a local stereo shop and asked about it and they said that i need a resistor pack a DRL box. but my Viggen i disabled the DRL so thats what i was wondering. When i first had them in the lights where flickering a bit. i have only seen some HIDS do that when there are stared up for the first time but this kept doing it until the fuse blew. Any ideas? ill look for that pin
 

·
Registered
Joined
·
1,043 Posts
HIDs shouldn't blow fuses in our cars. You probably bought a shitty kit.

That being said you might need a relay that runs from the battery to your ballasts. Those have their own fuses, too. Or just buy a new kit.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #9 ·
I had that idea too that i bought a shitty kit so i got a new one on order its a nice lumens kit from the local After market shop. I have used there kits before and there really nice and easy to use. is there a difference between a German ballast and a Digital one?
 
1 - 9 of 9 Posts
Top