Saab Link Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,591 Posts
Discussion Starter · #1 ·
On the 24th, while driving on the highway at slightly above average highway speeds, I heard a sound above the normal car noise that sounded like "ssssshhhhhhhhh!" it got louder as I accelerated, and then *pop!* and I could no longer hold boost pressure. When I accelerated again I heard the honking of the stock BOV and my boost never got above 9 lbs. Vacuum was not effected, so I am assuming that I didn't burst a hose or anything where vacuum would be lost.

When Got home I looked under the hood and everything regarding the silicone hoses, the MBC+A and intake looked to be intact and functioning normally.

I hadn't driven the car since last friday. When I came into work this morning, I accelerated a little to see if boost as available. It was and I got at least 12 lbs according to my VDO gauge. I didn't push it past that.

Could this just be that the BOV failed? Or is it something more... sinister? Any and all advice would be most greatly appreciated before I have to take it to the shop. Thanks!
 

·
Registered
Joined
·
745 Posts
Did you say stock BOV...as in Blow Off Valve..didn't know they came with the car stock :? :? ...I'd say you more likely have a stock BPV or Bypass Valve.., (or Diverter Valve for those across the pound) which most would recommend you get rid of, because they have a tendency to fail...

The BOV make the whssssh sound off mid to hard throttle, and between shifts typically.

But if you are referring to the stock BPV, I would have gotten rid it a long time ago.. depending on where you installed that MBC....and especially since you have one. I'd say you have a bad BPV indicative of the honking noise you described.

I have a black hi performance Hyperboost BPV for sale if your interested...I replaced it with my Forge BOV. PM me for the details..

regards
 

·
Registered
Joined
·
1,591 Posts
Discussion Starter · #3 ·
Yep, meant BPV. :oops: I am enjoying the effects of tylenol with codeine that I am on after throwing out my back yesterday. Sorry about that.

The thing that concerned me was not the honking, have had that before. It was the "ssssshhhhhhhh pop" sound. Would that be the diaphragm going south?
 

·
Registered
Joined
·
5,805 Posts
you know for what its worth ive never heard of a bosch valve failing with a "POP" they usually gradually start to "hoot" and thats basically it, shouldnt make you lose boost.

what that sounds like to me is one of the couplers on the intercooler piping blowing off under boost..but then as you said it wouldnt run too great after taht and you definitely would get 12psi outta it.

sounds weird, if it does turn out to be the BPV id be interested in pics of that since it sounds like something busted bigtime :lol: .

anyways good luck.

Paul
 

·
Registered
Joined
·
3,920 Posts
bevore you get too worried i would try and rplace the BPV and see how it runs... maybe get a friends stock one and see if thats all it is...and if you are still loosing boost then check out what paul said..
 

·
Registered
Joined
·
1,591 Posts
Discussion Starter · #7 ·
Good ideas, guys. Thanks. I think I can borrow a friend's BPV and see how that goes.

If it is the BPV, the thing is totally shot . Today while driving into work, I said screw it, let's see if it gets up to 15lbs. It did, but it didn't hold. There was no honking sound at all... Pressure dropped over the course of say, five seconds to 8 lbs and then bounced up to 10lbs and dropped down to 5 lbs and then bounced back up to 10 lbs again. After that, I eased off and just drove normally.

Another friend suggested I have the wastegate checked. I hope that this isn't the problem. A new wastegate is expensive, isn't it? Would these be symptoms of a bad wastegate?
 

·
Registered
Joined
·
1,591 Posts
Discussion Starter · #8 ·
Seems like it was the BPV. I tried another one and the performance was back to where it should be.

Did a little reading to see about how the bypass valve functions and my guess is that somehow it became "sticky" in the open position. It would close, but much slower than usual and it would open up again before the accelerator was fully released. Needless to say, driving felt very weird...

I ordered a forge (adonized red) BOV and blanking plug today. That'll be a fun post-Christmas gift to myself!
 
1 - 8 of 8 Posts
Top