Saab Link Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter · #1 ·
i have got to have some of the worst luck! at any rate as you might have guessed my tranni mount has completely failed. just take a look. the only thing that i can come up with to do is: weld in a large washer, maybe 2 with an opening about 10mm thick. then using a nut and bolt of the same size to fasten things down. of course with the new tranni mount from taliaffero.
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #2 ·
new mount woohoo!

i put the poli mount from genuine saab in and the results are amazing. the shifts are so much smoother. you can feel more vibration from the tranni. but it is well worth it. i bet in combo with mp's short shifter it is truely amazing! i reccomend this mount. by the way. if any of you are experiencing wobble etc in acceleration. take a look at your mount it could be cracked. mine was all the way through and was the source of my wobble.

enjoy

Ben Y.
 

·
HNNLIC
Joined
·
4,209 Posts
Im glad you got the mount replaced. Nice review of the Taliaferro mount as well. I may consider getting it along with another short shifter.

What type of vibrations do you hear?
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #4 ·
i had to do some rigging, by welding to the frame. but it works well. as for the vibrations. it is more feel than hear. you can feel it in the shifter and steering wheel. that is just going to happen when you put poli in the place of rubber. it really is a good upgrade. holds things much stiffer and therefor better shifts. before i would miss on hard shifts sometimes. not now and i have given it some good tests, just to se how it would act and feel.

Ben Y.
 
1 - 4 of 4 Posts
Top