Saab Link Forums banner
1 - 20 of 31 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter · #1 ·
My little 97 900se has been feeling like a pig lately. It has no bottom end but then starts to come alive again around 2500 rpm. Today it threw a code the P0172 bank 1 too rich. I checked my intercooler piping for leaks, checked the vacuum lines, and pulled the plugs. I didn't find any leaks and the plugs all look good/same so I don't think I have a stuck injector or anything. I swapped out my FPR thinking it may have failed and still nothing. I just swapped out my MAP sensor and still no dice.

What am I missing here. The oxygen sensors are new (last 3k miles) and it definitely smells like it is running rich and my gas mileage has dropped way down.
 

·
Registered
Joined
·
1,077 Posts
You say the plugs looked good, but what color were they actually and how old were they? The coolant temp sensor in the back of the motor could be bad, since its does influence fuel mixture. I'd look into that, since you've covered all the other bases it seems. And that part is cheap, like $15 from eeuroparts.com.
 

·
Registered
Joined
·
293 Posts
Discussion Starter · #3 ·
The plugs where light tan, I can't remember how old the plugs are. I went to pick up some new plugs but the autozone didn't carry the NGK plugs and I've always heard the Saabs are a little picky about plugs. The temperature gauge looks like it's reading the same as normal. Does the temperature gauge get the temp from the coolant temp sensor?
 

·
Registered
Joined
·
3,939 Posts
The plugs where light tan, I can't remember how old the plugs are. I went to pick up some new plugs but the autozone didn't carry the NGK plugs and I've always heard the Saabs are a little picky about plugs. The temperature gauge looks like it's reading the same as normal. Does the temperature gauge get the temp from the coolant temp sensor?
no separate sensors
 

·
Registered
Joined
·
1,077 Posts
Yeah that sensor has NOTHING to do with your temp gauge. The gauge is controlled by a separate piece entirely. It's the coolant temperature sensor for the computer, not the gauge. eEuroparts - Coolant Temp (NTC) Sensor - # 15393755

That is the piece you need. The hardest part is swapping it out.
 

·
Registered
Joined
·
1,077 Posts
The plugs where light tan, I can't remember how old the plugs are. I went to pick up some new plugs but the autozone didn't carry the NGK plugs and I've always heard the Saabs are a little picky about plugs. The temperature gauge looks like it's reading the same as normal. Does the temperature gauge get the temp from the coolant temp sensor?
Oh and fuck autozone. I used to work at one, and half of the employees there were either retarded in a medical sense, or just stupid. They do sell BCPR7ES11 plugs, as does Advance and NAPA. You just have to get someone who isn't a total moron, and can listen. They only want to sell you their monthly specials or whatever they have on hand.
 

·
Registered
Joined
·
1,487 Posts
Ugh... I have a cold start issue and believe the CTS to be the culprit ... sob... oh well change the fuel injectors with the 38lb 93 aeros while i'm at it? anyhow it takes like 4 times to start and when it runs it runs rich so i guess i'm gonna swap that out.
 

·
Registered
Joined
·
1,077 Posts
Ugh... I have a cold start issue and believe the CTS to be the culprit ... sob... oh well change the fuel injectors with the 38lb 93 aeros while i'm at it? anyhow it takes like 4 times to start and when it runs it runs rich so i guess i'm gonna swap that out.
Extended start times would be more likely caused by the check valve in the pump assembly going bad. CTS causing richness wouldn't affect starting, just running rich once its warmed up. Or a variety of other parts maybe.
 

·
Registered
Joined
·
1,487 Posts
Extended start times would be more likely caused by the check valve in the pump assembly going bad. CTS causing richness wouldn't affect starting, just running rich once its warmed up. Or a variety of other parts maybe.
if i have to yank the fuel pump out i'll be pissed
 

·
Registered
Joined
·
1,077 Posts
if i have to yank the fuel pump out i'll be pissed
Nope, its on top of the pump, but you do have to actually GET to the pump. So either the hole in floor method, or drop the tank. And do yourself a favor and pick up the recall kit for the retainers that hold the valves into the pump assembly.
eEuroparts - Fuel Line Retainer Clip - # 12806113

That little plastic bit along with the valves cracking (i got lucky, none of mine broke, but still replaced along with the retainer) can make for a bad day really easily. Cheap, and keeps your car from being a rolling bbq.
 

·
Registered
Joined
·
1,077 Posts
Thanks for posting the link to that part. I looked all over and couldn't find it.
No problem, that site is handy, and I just did a lot work to mine so I wanted to pass some help along. The CTS will require you to remove/loosen a lot of stuff in the fuel rail area, but its good because you're then familiar with a lot of things back there you might not otherwise look at. Also good time to check vac lines and replace if they're old.
 

·
Registered
Joined
·
252 Posts
i ended up not having to remove the fuel rail when i changed the CTS in my car. it was a tight fit, but i was able to do it with an open end wrench, and a lot of body contorting,

still easier than removing the fuel rail.

oh, and i have similar issues as you, and replacing the sensor didn't help mine.

i also have recently replaced the fuel pump, it's not too bad if you do the hole through the floor method.

i'm not sure if it's specificially what happened, but if you do it, i would recommend filling your tank completely before you do it (counter intuitive i know) but once i hooked the new pump and assy back up, the point it the gauge thinks is full is the level the fuel was at when i reconnected the pump. i'm just dealing with the uncalibrated gauge for the time being, knowing that 5/8 on the gauge means that it's somewhere more than that full
 

·
Registered
Joined
·
1,077 Posts
i ended up not having to remove the fuel rail when i changed the CTS in my car. it was a tight fit, but i was able to do it with an open end wrench, and a lot of body contorting,

still easier than removing the fuel rail.

oh, and i have similar issues as you, and replacing the sensor didn't help mine.

i also have recently replaced the fuel pump, it's not too bad if you do the hole through the floor method.

i'm not sure if it's specificially what happened, but if you do it, i would recommend filling your tank completely before you do it (counter intuitive i know) but once i hooked the new pump and assy back up, the point it the gauge thinks is full is the level the fuel was at when i reconnected the pump. i'm just dealing with the uncalibrated gauge for the time being, knowing that 5/8 on the gauge means that it's somewhere more than that full
For me, pulling the rail out of the way takes no time at all. Was easier for me than fighting with a wrench for a while. Also, fuel level can be reset via Tech 2 if you have access to one. Although my fuel level was only maybe half when I put in the assembly, and it didn't seem matter.
 

·
Registered
Joined
·
293 Posts
Discussion Starter · #15 ·
Well swapped out the CTS sensor and it didn't seem to help. I got mine with a 19mm crowfoot and like a 12" extension. The CTS sensor did seem suspect the new one is like 4.8k and the one that came out read like 500 ohms so I'm sure it was faulty. I'm frustrated with this thing, it has no power until like 3500 rpm.
 

·
Registered
Joined
·
1,077 Posts
Well swapped out the CTS sensor and it didn't seem to help. I got mine with a 19mm crowfoot and like a 12" extension. The CTS sensor did seem suspect the new one is like 4.8k and the one that came out read like 500 ohms so I'm sure it was faulty. I'm frustrated with this thing, it has no power until like 3500 rpm.
Ok, so youve changed o2 sensors, plugs, now cts? Maybe one of the others will chime in. Something is being overlooked. Have you checked to see if you smell gas in the vac line to the fuel pressure regulator? That would be a clue to whether it is good or not. They leak when they get old sometimes.
 

·
Registered
Joined
·
293 Posts
Discussion Starter · #17 ·
The FPR was actually one of the first things I checked. I didn't smell fuel in the vac line but I swapped in my spare just in case. I also went over the engine with an unlit torch looking for vacuum leaks and didn't find anything. The vacuum lines all look good, my intercooler hoses are decent but no major leaks.

I'm sure its something stupid I'm missing. The only other things I can think of is a throttle position sensor or possibly a failing DI.
 

·
Registered
Joined
·
1,077 Posts
The FPR was actually one of the first things I checked. I didn't smell fuel in the vac line but I swapped in my spare just in case. I also went over the engine with an unlit torch looking for vacuum leaks and didn't find anything. The vacuum lines all look good, my intercooler hoses are decent but no major leaks.

I'm sure its something stupid I'm missing. The only other things I can think of is a throttle position sensor or possibly a failing DI.
TPS won't affect mixture, although it would make your car run funny due to the computer not knowing where the throttle plate was if the part were bad. But if its just richness and not a running issue, thats probably not it. A DI could be a problem though. Do you have a spare to swap in?
 

·
Registered
Joined
·
293 Posts
Discussion Starter · #19 ·
Well got a new set of plugs in from Summit today gapped them and figured while I had them out I would check compression. With all four plugs out cylinders 1,2, and 3 show about 125 psi and then drop to 0 as soon as cranking stops. Cylinder 4 goes to 125 psi and holds slowly leaking down after cranking stops. With plugs in 3 cylinders all cylinders read 125 and hold after cranking. I'm not sure why this would happen a stuck valve???? Anyway took it for a test drive with new plugs and its horrible. Come back home swap my DI cassette for my spare and take it for another ride it's just as bad maybe worse. WTF!!!!!!
 
1 - 20 of 31 Posts
Top