Saab Link Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter · #1 ·
I have two questions:

1. Today "Time For Service" popped up, does this mean it needs service or is it just an automated message every so and so miles?

2. A few days ago when I turned my car off, one of my head lights stayed on and I tried every switch and button for the lights and nothing. Before this, one of my fog lights went out and only one side high beam works and now that one high beam stays on with the regular light. The only way to turn the light off is if I take the Light Control Relay out when I turn the car off then back in when on, which is REALLY annoying. Also one rear fog light doesn't work anymore no matter how many times I change the bulb. (Already got a ticket for "Break Light Out" lol silly cop didn't know until I told him it was my fog light) Would a bad relay be causing this?
 

·
Registered
Joined
·
3,059 Posts
Your car only came with one rear fog light. You can add a second bulb in; there is a socket for it on the passenger side of the hatch.

Out of curiosity did you have them on during clear weather or nasty weather? I'm trying to figure out why the Cop would pull you over...they aren't brake lights.

Anyway the other issue...Those orange Lamp control relays always go bad.
You can try to take yours apart and re-flow the solder connections, this may do the trick and last you a while.
Otherwise you should just go to a junkyard and pick a bunch of them up. Hopefully you will pick a few working ones.

As for the front fog lights, one of those going out is most likely coincidence as those are not controlled from the lamp control relay.
 

·
Registered
Joined
·
275 Posts
Discussion Starter · #5 ·
Yea I added another rear foglight. This was about a year or so ago and I can't remember if it was either the foglight out one of the break lights, and it was during the evening. Maybe he was just being a prick :roll:

Damn why didn't I think about getting some at the junkyard! I had planned on looking for a DIC, but thanks for reminding me.

Do I need a new fog light relay, fog light bulb, or what?
 

·
Registered
Joined
·
275 Posts
Discussion Starter · #8 · (Edited)
I took one apart and it looks fine :confused:

**Update: wiggled the relay around and the headlights started to turn on and off but only one at a time and then wiggled a different way and they turned off. And if I pushed it in all the way they would stay on. Now the headlights work and turn off when I shut the car off but no highbeams and still one foglight
:evil:
 

·
Registered
Joined
·
5,111 Posts
Just because it looks fine doesn't mean it is. There are micrscopic cracks in the solder joints where the board meats the base.

Maybe your socket is messed up to, does it look melted?
 

·
Registered
Joined
·
275 Posts
Discussion Starter · #10 · (Edited)
now that you say that, on the soldered side of the relay there were two connections melted together from being soldered, but i don't think that's the problem because it wouldn't get that hot? and i tried 3 different ones.
where would the socket be?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top