Saab Link Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
so today i did all the checks i could without a computer diagnostic. the check valves had around 70 ohms resistance and then later i checked them again and the one attached to the bypass valve was an open circuit. the vacuum lines were all checked and seem to be holding. i took the tb off and cleaned and checked the resistance between 7 and 1 and got anywhere from 10 to 500 ohms, not linear. the tcs fuse had power before the car was started but as soon as it was running it went off, i jumpered it and heard a relay click and a small hesitation in the engine then no difference. There is no ABS light on and i disconnected the wastegate line just to check the boost, it pushed out like 20 psi in no time at all, i didn't dare do a pull at that pressure but it sure feels nice to feel 10 psi after driving it around at 3 all the time. after all the checks today it seems to be idling better and has slightly better throttle response, but its still a dog. So what can i do next, should i start throwing parts at it or does a mechanic have to calibrate it or what? thanks again
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #2 ·
so today i took my car to the mechanic, he scanned it quick and said it was the safety valve, he reset the tcs code and told me that if i leave cruise on it will calibrate it every time you turn it off. and the ac pumps again. so until the new valve is in i have a trouble code but its not running in limp mode any more :D
 
1 - 2 of 2 Posts
Top