Saab Link Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
252 Posts
Discussion Starter · #1 ·
so my stock amp keeps blowing out the internal fuse... it is supposed to only be a 15amp fuse right? would that be a sign of an internal short or something somewhere else in the stereo wiring system to the door speakers... any way to test and find out?
 

·
Registered
Joined
·
130 Posts
I'll take a stab at this...

Depending upon how often it blows you could try disconnecting the speaker wires for a while.

Make sure the grounds are...grounded.


I just can't imagine that there would be enough current going through the speaker wires to blow a fuse if you have a bad wire. Check your grounds first or add one if there aren't any.

By no means am I an expert or amateur for that matter on this.
 

·
Registered
Joined
·
252 Posts
Discussion Starter · #4 ·
it's the stock amp. from behind the center console panel in the passenger foot well. the fuse was blowing instantly. cracked it open yesterday and the amp my multimeter and i spent some quality time together. everything checked out except the two output mosfet transistors. one was totally shorted out and the other was half closed where it should have been open. the rest of the components tested in their spec that they should. the amp isn't rusty or anything visibly it's in great shape. i'm trying to source some replacement transistors to replace the blown ones with but it seems that motorola stopped making them a decade ago and they've been replaced with lower power models.
 

·
Registered
Joined
·
130 Posts
If you wander over to the Selling section you'll see I have a stock amp for $15 available. Plus, a whole lot of other parts.
 
1 - 5 of 5 Posts
Top