Saab Link Forums banner
1 - 15 of 15 Posts

·
Baby's Got a Temper
Joined
·
37 Posts
Discussion Starter · #1 ·
Hi,

On Monday, while I was driving to work, the car lost power for a moment and eventually stalled. After pulling over and accessing things I attempted to start her back up. She did start but ran for 2-3 seconds before stalling again.

Called the tow truck and had it over to my local shop. They diagnosed a bad crank sensor and replaced it. Great.

After picking the car up I took her for a test ride and she seemed fine. Got home, pulled into the driveway and... she stalled. It seems to be the same exact symptoms...

Here are some clues:

- The weather has turned particularly cold here this week and,
- it seems to happen after the car has sufficiently warmed up.
- She starts and runs fine from cold.
- She got a recent (within 100 miles) oil change.

Is this a classic NTC issue?
 

·
Registered
Joined
·
1,643 Posts
I had a very similar case with a 97. Relaced crank sensor, Towed back dead. Replaced fuel pump & relay, towed back dead. Soldiered every connector pin related to what I thought could cause such a problem. towed back. Replaced "Brand NEW SAAB OEM crank sensor with another brand new SAAB OEM crank sensor. Clear sailing for many years after,

A stuck open ELCD valve could also cause your Stall. If you can Blow through it, Its bad. Some times they close fine and other times they stick open, Still can cause a stall thats hard to pinpoint. Good luck.
 

·
Baby's Got a Temper
Joined
·
37 Posts
Discussion Starter · #3 ·
Thanks Harvey's!

Now to figure out the best way to pass this info along to my tech without sounding like a smartass...
 

·
Registered
Joined
·
1,077 Posts
Thanks Harvey's!

Now to figure out the best way to pass this info along to my tech without sounding like a smartass...
I take it he's not a Saab guy? My MAP sensor got fried by something stupid I did, and that caused a hell of a mess for me. My main clue was that the car was running so rich it was insane. Let us know if you get it figured out. That and one or more of our members probably lives somewhat close to you and might be able to help later if you need something.
 

·
Registered
Joined
·
1,413 Posts
Im having the same symptoms with my viggen... cold starts it will be fine then once it warms up I start to have issues. It will on my way to and from work (20 miles each way) occasionally jerk once or twice while driving almost like pressing the clutch in and popping it. If I pull up to a stop sign just after starting it it will randomly stall once every other day. I was thinking crank sensor could be the only issue. When it does stall it wont start back up but if i get it rolling and pop start it that car starts. I saved myself at a few stop signs doing this. think its a crank sensor?
 

·
Baby's Got a Temper
Joined
·
37 Posts
Discussion Starter · #6 ·
I take it he's not a Saab guy?
Ya, he's a Saab/Volvo tech. I just don't want to give him the impression that I'm off getting 2nd opinions because I don't trust him. He's been great, actually.

Let us know if you get it figured out. That and one or more of our members probably lives somewhat close to you and might be able to help later if you need something.
I'll keep everyone posted. And, yeah, I've met some locals who seem eager to wrench. I'm actually stockpiling beer for such an occasion.
 

·
Baby's Got a Temper
Joined
·
37 Posts
Discussion Starter · #7 ·
Im having the same symptoms with my viggen... cold starts it will be fine then once it warms up I start to have issues. It will on my way to and from work (20 miles each way) occasionally jerk once or twice while driving almost like pressing the clutch in and popping it. If I pull up to a stop sign just after starting it it will randomly stall once every other day. I was thinking crank sensor could be the only issue. When it does stall it wont start back up but if i get it rolling and pop start it that car starts. I saved myself at a few stop signs doing this. think its a crank sensor?
I don't think we're experiencing the same (exact) symptoms. My car just loses power and stalls; no jerking. And there's no way to keep the car running without letting it cool for several hours. My car does turn over and starts, but runs for a few seconds before stalling again. There's no way in hell I'd drive anywhere because, once it warms up enough, it won't stay running no matter what I do.

Having said that, I'm not savvy enough to rule out the crank sensor. I defer to others here. Keep us posted of your progress.
 

·
Registered
Joined
·
1,643 Posts
Im having the same symptoms with my viggen... cold starts it will be fine then once it warms up I start to have issues. It will on my way to and from work (20 miles each way) occasionally jerk once or twice while driving almost like pressing the clutch in and popping it. If I pull up to a stop sign just after starting it it will randomly stall once every other day. I was thinking crank sensor could be the only issue. When it does stall it wont start back up but if i get it rolling and pop start it that car starts. I saved myself at a few stop signs doing this. think its a crank sensor?
on a Viggen? those symptoms all sound like your Throtle body is about to jump into limp home.
 

·
Registered
Joined
·
8,796 Posts
on a Viggen? those symptoms all sound like your Throtle body is about to jump into limp home.
I had symptoms like that when my cps died. When the tb went I git weird stumbling when giving small throttle input when going up a hill but cruising was fine.
 

·
Registered
Joined
·
1,487 Posts
hes going to hate all of you for referring to him as a/the doctor... he blew up on somebody about that already irc
 

·
Baby's Got a Temper
Joined
·
37 Posts
Discussion Starter · #13 ·
Just following up regarding my OP. It turns out my A/C compressor has self destructed... Zoddamn things are spendy! :shock:
 

·
Moderator
Joined
·
10,303 Posts
In that case, since you wont need it for a few months, I would just bypass it and put some $$ into a jar every week untill it gets hot out.
 

·
Baby's Got a Temper
Joined
·
37 Posts
Discussion Starter · #15 ·
Ya, that was the plan. Wife didn't like that idea so I had Santa find a used compressor. Ugh.
 
1 - 15 of 15 Posts
Top