Saab Link Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,

I have Saab 9-3 2003 model. I have a big problem with electrical system.

Sometimes, the front panel (speedometer, rpm, fuel guage etc) goes off and comes back again. Even the side indicator lights stop working. At times, I keep on getting warning messages, like, Airbag malfunctioning, Gearbox malfunctioning. But car works fine.

I have noticed, the headlights work all the time. At times, it gets even difficult to start the car when this electrical fluctuation happens.

Initially, mechanic thought the problem would be with ignition system. But the problem continued after replacing something related ignition (don't know what). Now, they think, it's probably related to CAN cables.

Has anyone of you faced such issues? Car otherwise works fine.

Please help!
 

·
Super Moderator
Joined
·
6,721 Posts
I deleted your other thread as a duplicate. Stick to this one.
 

·
Registered
Joined
·
3,022 Posts
Lots of things can cause this, could be CANbus wiring, could be computer module starting to fail, could be loose or bad connections at ground lugs or coming out of power supply panels.

It may be nearly impossible to isolate the problem without the SAAB factory diagnostic tools and wiring diagrams and a talented technician.

I faced symptoms like this probably half a dozen times already, and it was caused by a different thing every single time.

My best advice would be to get the car to a good local shop who really knows the 9-3SS cars.

Good luck.
 

·
Registered
Joined
·
12 Posts
hi I am have a problem on my saab 93 aero in radio panel system . it was make a Electricity smuggling and make a down for battery if not start more than 3 H .

I am check with mechanic and confirmed the radio panel make a smuggling to the car after he test all cables computers on car .

aucaly I don't now what I need to do if I emove the device the car not work because their is a security system in radio panel .

Do some one have a same problem and fiex?

please I need you help
 

·
Registered
Joined
·
3,022 Posts
For the sake of others, daqqaq sent me the basically the same question but more focused towards a drain coming from the radio / entertainment system. My response was:

"Hi,

The most common problem with the radio draining the battery is the amplifier under the driver's seat. You could try unplugging it and see if the battery drain goes away.

The main radio control panel must be plugged in for the car to start.

Does the radio work? Does it turn on but no sound? Is there sound from the turn signals?"
 

·
Registered
Joined
·
12 Posts
thanks mrs drew

radio not work if I switch off car , no it not turn on , I hear a sond after switch off car from radio panle . do I should change the amplifier ?

thanks
 

·
Registered
Joined
·
3,022 Posts
Try unplugging the amplifier and see if the battery drain goes away. With it unplugged the radio will still not work - to diagnose the radio your shop must have the factory scan tool (a Tech2) and some knowledge, they are a little tricky.
 

·
Registered
Joined
·
12 Posts
hi searching for best , I was remove the amplifier under seat driver . and I but new battery because the electrical drain was make my battery day .

now my car is ok . try to check the amplifier as per Drewp advice me . and now I need to searching for new amplifier which I don't find .
 
1 - 9 of 9 Posts
Top