Saab Link Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2,754 Posts
Discussion Starter · #1 ·
The brakes on my wife's '93 CSET feel like shit. The pump works when you turn the key on and there are no lights but I was just bleeding the front calipers and the pump did not kick back on. The bleeder was opened, fluid came out for a short time and that was the end of it. Had to do the process over again to get more fluid. Shouldn't it be a steady stream?
 

·
Registered
Joined
·
10,049 Posts
"feels like shit" meaning what? Pedal is too hard/soft? Brakes just delay before grabbing? More details help - Sure it could be the Nitrogen ball, but I wouldn't just throw parts @ it w/out getting some more details and diag on the situation.
 

·
Registered
Joined
·
3,022 Posts
So the pump does run when with key --> 'RUN', engine off?

Those ABS controllers can have problems with pins in the electrical connectors either get pushed out of the connector, or they get corroded. There are about 5 connectors, pull them all off, look in and make sure all the pins are ok, and that none are all stretched out.

The pump is triggered by a pressure switch, screwed into the side of the hydraulic block, it actually looks sort of like the timing chain tensioner, about the same size. Make sure the connector on that guy is OK. Sometimes the switch will get stuck and stop running the pump when the accumulator pressure gets low.



Drew
 

·
Registered
Joined
·
10,049 Posts
And that switch does often go bad - I have replaced a few of those before on 9-5's and Sport Sedans - never on a 9000 yet. Almost sounds like it could be the nitrogen ball - but that all depends on your answers to the above questions.
 

·
Registered
Joined
·
1,022 Posts
where was this info when my pump went bad? I ended up buying a new pump. and building up my right calf.
 
1 - 10 of 10 Posts
Top