Saab Link Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter · #1 ·
At warm engine I get a pretty loud pinging at low load, and between 1500 to 2000 rpm. To me it sounds like pre ignition pinging, and not any mechanical noise. I tried= cooler spark plugs, new thermostat 80 celsius. I opened up my exhaust since I had a pretty high backpressure, checked catylic converter. New O2 sensor. Now I suspect that former owner had a blown headgasket and someone just fixed the surface on a bent head, because I have 0,5kg higher compression on the cyl. 1 and 4, compared to cyl. 2 and 3. There is also residue of oil in the coolant reservoir. I have newer before experienced a low load/ low rpm pinging, in my life. I been driving around like this for 8 months now, and since the pinging goes away at higher rpm, i'm not worried driving it. Im thinking off pulling the head and see what info that will give me. I cant read any code, because grounding the pin in my ODB 1 outlet is not working, and I dont know anybody with a Tech 2. The lamp is not on anyway. I have not checked the knock sensor yet, bought a oscilloscope last week, so that is next. Any tip?
 

·
Registered
Joined
·
1,837 Posts
Yeah got this same issue on my 2.3 NA. Here is the situation, compare it to yours:

Through gears 2, 3, 4, at low rpm, between 1500-2500, there will be a pinging/crackling sound. I originally thought it was the transmission, but it is most certainly the engine. Pretty similar to yours. I have had this for well over a year.

I took apart the distributor, putting on a new one, new plugs + wires and it went away a little bit. After putting 93 octane in the car (previously running 89), it went away almost completely. You can now only hear it after running the car for a long time, when the engine gets really hot.

Try running 93 octane if you aren't already (mpg's make up for the price), and take a look at the dist. to see if it is leaking oil slowly like mine was. It must also be said that my car burns oil, less than it used to but still does burn it. 194k and not worried at all.
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #6 ·
I should had put this thread under "car problems". Sorry.. I'm new to this forum. Yes it's a Motronic. I did put in NGK-BCPR7, and it didn't change a thing. It does not take any oil at all. The compression is: 14,6, 14,0, 14,0 and cyl. no 4: 14,6 kg. Something like 210, 190, 190, 210 psi. Anyone has any idea's about that pressure? Also, I run on Shell 93, V-Power hoping that the cleaning effect of that gas might remove some carbon in the combustion chambers? If I have any? Interesting that you have the same problem Aikmanson. I can take the car for a run to work, no pinging. But after standing and waiting for food at a drive thru, I get a crazy pinging taking off. One day this summer 102 farhenheit outside, the car was even pinging at 15 miles/h, around 1800rpm, DOWNHILL, with almost no push at the gaspedal at all. I couldn't do anything but laugh.
 

·
Registered
Joined
·
1,837 Posts
I should had put this thread under "car problems". Sorry.. I'm new to this forum. Yes it's a Motronic. I did put in NGK-BCPR7, and it didn't change a thing. It does not take any oil at all. The compression is: 14,6, 14,0, 14,0 and cyl. no 4: 14,6 kg. Something like 210, 190, 190, 210 psi. Anyone has any idea's about that pressure? Also, I run on Shell 93, V-Power hoping that the cleaning effect of that gas might remove some carbon in the combustion chambers? If I have any? Interesting that you have the same problem Aikmanson. I can take the car for a run to work, no pinging. But after standing and waiting for food at a drive thru, I get a crazy pinging taking off. One day this summer 102 farhenheit outside, the car was even pinging at 15 miles/h, around 1800rpm, DOWNHILL, with almost no push at the gaspedal at all. I couldn't do anything but laugh.
Do you get it in 1st gear? Cause I don't at all, since the car is not under much of a load. For me, it is throttle dependent, within those rpms, within those 3 gears (2,3,4). If I lets say, give it a little gas, I can rev through 3000 in 2nd gear with no ping, but if I give it an average amount, it will most likely ping through 2500 (if the car is hot).
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #9 ·
It sounds like our problem are very similar. I'm not sure which gear, but since I have taken off and the trans shifts over to 2nd very quickly, I think it is in 2nd. Here the reason this it's bathering me. I'm running in a huge park, and I have to drive 3 miles in this park at 20m/h. It pings a lot, mostly uphill, at a 1/4 of gas pedal movement maybe. If I give more gas uphill and pass 2300-2500rpm it stops pinging, but then I'm doing 30m/h, and the speed limit is 15, and the police is everywhere. I dont think they will accept my excuse, that I have to drive double speed limit to avoid pinging. I think at my Christmas break the head is coming off. Any one knows about different thickness off head gaskets?
 
1 - 9 of 9 Posts
Top