Saab Link Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 92 900 S Turbo with a manual transmission and twice now I've had someone else that's driven it and didn't realize you had to put it in reverse to take the key out. Both times, after asking me, they did put it in reverse to remove the key - but shut the car off with the transmission either in neutral or another gear (I didn't ask as it wasn't until it happened the second time I realized this may be an issue). Anyway, both times right after that happened I lost so much charge on my battery my alternator wasn't able to keep up and my car died. Is anyone else having this issue? Is this something common or is it a possible sign of a bigger issue? Thank you!
 

·
Registered
Joined
·
2,522 Posts
If they're leaving the car "on" but not running, there are plenty of things that will drain the battery, and it's to be expected.
 

·
Registered
Joined
·
431 Posts
900S Turbo ? ...did someone swap a turbo motor into it?
Be very careful about not training anyone who drives your C900. People who don't understand the reverse-lock will eventually trash the ignition, including shop personnel.
If you're getting it started, then the battery is good enough to run it. Is it actually charging?
The key should turn to 'off' in any gear, leaving no draw on the battery. Did everything shut off, lights, etc? Being in reverse is only necessary to get it to 'lock' and remove the key.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
No, it came from the factory as a 900S Turbo. I researched it once and it turns out between four or five years in the late 80's, early 90's, they manufactured 48,500 900S convertible models with the turbo engines. I happened to have come across one of them a couple of years ago and bought it. Great little car, runs like crazy - can climb mountain passes (we live in CO) in 5th gear at 80 mph, gets 30 mpg, couldn't ask for a better car except for this current battery issue.
 

·
Registered
Joined
·
431 Posts
Interesting. I hadn't heard of that mixed model designation before.
How's your troubleshooting going? Have you had battery issues since those couple times mentioned above?
 
1 - 5 of 5 Posts
Top