Saab Link Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 1995 9000 aero w/ tcs. I've got no voltage @ the safety runoff valve. I just did a head gasket on this car. It ran great when I took it apart. I put it back together and after running it for 2 days it went into limp home and left me stranded. Any ideas would be greatly appreciated. thanks
 

·
Registered
Joined
·
12,348 Posts
I'd check the wiring connection at the valve itself and make sure one of the pins hasn't backed out of the plug.
 

·
Registered
Joined
·
3,022 Posts
I sent a message to this guy, I will re-post it here so the info is public in case it helps someone else out down the line:

TheDrew said:
I am not actually certain that you should have voltage there unless the engine is running, under what conditions are you testing it?

I believe the safety valve is switched on through the ETS ECU that controls the electronic throttle, you may have to back trace the wires and see if there is a break there.

Also double check all the fuses before you drive yourself crazy, there are two that power the electronic throttle system in the fuse panel under the glovebox.

There may also of course be some reason that the ECU is not powering the safety valve, like a fault in the throttle body itself - you will drive yourself insane trying to diagnose it without finding somewhere that can read the ETS fault codes for you.

Drew
Unless you have a retracted pin or break in the wiring, my last comment alludes to the sensitivity of the TCS/ETS system in the 9000 - there are easily 50 individual reasons the system can go into limp mode, and when it does it cuts power to the safety valve, forcing it into limp mode.

It's also possible that when you did your head gasket the new possibly higher compression threw the system's adaptation off enough that it just needs to be re-calibrated. The TCS manual says that any major engine work which would affect air mass like changing turbo, head gasket, rings, etc. needs to be followed by a calibration procedure to re-zero the system.

Had that be the fix on a few of my cars, there's no telling what extended periods of time with power cut to the ECU/ETS will do to 25 year old analog electronics. When I bought my last '93 it was in limp and just needed to be calibrated.

Never know with these cars, but even if you have to drop $100 for a SAAB shop to read the ETS codes for you it'll be $100 well spent since you'll actually know what the problem is.

Drew
 
1 - 6 of 6 Posts
Top