Saab Link Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
385 Posts
Discussion Starter · #1 ·
Just got car on Thursday (idle a tad rough,even when engine is warm). Later in day my husband filled up with premium. He came home, car smelled like there was a gas leak. Running it around, rough idle worst, on accellerating feels like it is going to stall, but doesn't. At idle, engine feels like it's missing, jumping, popping and you feel it through the whole car.

Haven't had time to investigate it. Either we got really bad gas, plugs are fouled, or someother unknown. Don't remember the car running like this test driving last week. Told my husband to park it, don't want to mess anything else up.

Anyone else experiance this, or have any thoughts, please post. We will check the plugs out later and hope it's an easy fix. Not a great weekend for this to happen :rolleyes:
 

·
Registered
Joined
·
270 Posts
Where are you smelling gas: engine bay, inside the cabin, outside the car? I would start with the easiest/simple: vacuum leaks (pcv valve, lines from crankcase, lines running around the engine bay). I would go ahead and replace the air filter, spark plugs, and fuel filter. Could be a tank of bad gas...run some techron or other fuel system cleaner.
 

·
Registered
Joined
·
385 Posts
Discussion Starter · #4 ·
Where are you smelling gas: engine bay, inside the cabin, outside the car? I would start with the easiest/simple: vacuum leaks (pcv valve, lines from crankcase, lines running around the engine bay). I would go ahead and replace the air filter, spark plugs, and fuel filter. Could be a tank of bad gas...run some techron or other fuel system cleaner.
is the gas cap on?
Gas cap is on. Smelling gas outside the car by gas filler door pass side. We were thinking bad gas so we will try the techron and also maybe a clogged fuel injector.

Thanks for your imput. Will it hurt the car to drive it like this?
 

Attachments

·
Registered
Joined
·
4,702 Posts
could be these items

Throttle position senser (check this by umplugging it, a failed TPS will make a car run worse than an unplugged one)
Air mass meter
Fuel presure reg
o2 (unlikely, but still possible)
ecu (incredably unlikely)
or a vac leak (most likely!!!!!!!!! if this is a non ABS car make sure to check the brake booster too)
mike
 

·
Registered
Joined
·
385 Posts
Discussion Starter · #7 ·
Could be a tank of bad gas...run some techron or other fuel system cleaner.
Put techron in and car is running Great. Happy, Happy, joy, joy :p Husband filled up with Mobil. Hope it's OK. My 92 always ran like crap after using Mobil, which Saab confirmed. Hope the reformulation took that problem away!!

Now A/C compressor may be bad. PO had it checked in May,and diagnosis said it may have water it in. How it's an easy fix. Compressor doesn't even turn on. It does in my 86, but system needs to be recharged.
 
1 - 7 of 7 Posts
Top