Saab Link Forums banner
1 - 20 of 37 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
Just installed my new Maptun Stage 3 ECU for my 1999 9-3. Power has increased but feels only like a stage 1. I have all the necessary mods for the stage 3 (3" DP, Vig IC, 2.5" cat back, Vig BPV, etc.). My concern is, and I am assuming it is my car and not the software, that when I floor it, the stock turbo boost guage travels only halfway into the yellow. This mirrors the boost pattern for my stock ECU. Shouldn't the stock boost guage be pinned int the RED?. Any help would be much appreciated!
 

·
Registered
Joined
·
729 Posts
you also might have a boost leak in one of your pipes.
just a thought.

Also take it to the dyno to see if the HP is accurate with the stats
 

·
HNNLIC
Joined
·
4,209 Posts
It should be definately boosting into red.

I'd give them a call about it.
 

·
Registered
Joined
·
475 Posts
You should be boosting more than that with your stock ECU. There is probably a leak somewhere or a faulty valve as suggested if both ECU's are getting to the same point (on the stock boost guage) and then dying.
 

·
Registered
Joined
·
745 Posts
My stage 3 Maptun had me boosting just above the red.. but I have a t5. Are you running a t7? Cause I'm not sure you would see into the red like you do on a t5. Any chance you installed a real boost gauge to see if any difference between stock and Maptun?

I had a vacuum line that had a hole in it near the base of my throttle body, but still managed to peg the boost needle. I noticed a change when I turned off my climate control. I mean very noticeable. But I also kept my stock ECU just in case of a problem, or return on the product was required.

good luck..
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #8 ·
OK, first of all thanks for all the input!

Roadkil - I do not have a mbc.

Trexturk - Exactly what pipes are you talking about?

DC Saab - My 9-3 is also a T5

Has any one experienced a symptom before where boost was ok but just stopped at a certain point and held there. I don't have any spikes at least from what I can tell from my stock boost guage. My BPV is the upgraded bosch BPV. Would that stop me from reaching max. boost compared to an aftermarket valve?

If it is a vacuum line would boost problems be similar to what I am currently seeing?

If it is a loose IC pipe, would that be consistent with what I am seeing?

Could it be my wastegate?

Just trying to isolate this before I go buy all new pipes, lines, and valves. Keep the input coming I welcome all!
 

·
Trollerator
Joined
·
9,830 Posts
I have a Maptun stage 1 (T7) and I go well into the red. Sorry, no boost guage yet so I can't give you a number for boost psi. just an fyi, for t7 stage 3 is only like 10 HP more than stage 1, it is more about better top end power and breathing than a massive peak HP gain. not familiar with the t5 upgrades, though.

Did you try unpluggin the Boost solenoid thing and see what happens. this is a easy way to see if the solenoid is working, right? you should get base boost, halfway into the yellow/orange... if you get wild crazy uncontrollable boost then it is not working. Someone correct me if i am wrong. :wink:
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #11 ·
Abduckted,

That's exactly where it is halfway between the yellow/orange. It sure feels like I'm only getting base boost. Can you direct me to where the boost solenoid is?
Tx.
 

·
Registered
Joined
·
3,976 Posts
My car had very similiar experiences but then it flipped to the opposite and I was pegging the top of the red in every gear and I didnt have a reprogrammed ECU!! IT turned out to be my Boost Pressure Control valve and now all is well.

Right side of the car next to the Radiator and is a metal 3 hose barb device. On a T5 it is a fairly expensive piece to replace so you want to find someone close to you with a good working T5 and swap with them and see if the issue goes away or not. If it does then you know thats the issue and you can goto http://thesaabsite.com and get it fro like $200 or so.

93 99-03 Boost Control Valve B204 Engine only NOT VIGGEN
OES 7485576 $ 215.00

or if you are lucky you have the plastic valve located near where the other one is but on the block side of the engine bay intead of on the radiator.

93 99-03 Boost Control Valve B205-B235 Engines
OES 9175290 $ 44.00
 

·
Registered
Joined
·
1,253 Posts
instead of buying a bpc i would try a boost controller... then u will know if it is the bpc or if in fact your car is in limp home mode... also try a new bpv.... and i wouldnt make a conclusion just by what your stock gauge says as it has been said many time shtat this is subjective... my car has hit 14 psi b4 and the stock gauge only says its 1/4 in red i believe.. i dont even look at that gauge anymore
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #14 ·
steve and Ricot,

Thanks for the input I'll look into it. Unfortunately, I have the 204 Engine. But if that's the problem it makes sense to correct. Any way to check the Boost Pressure Control Valve without replacing it first?
 

·
Registered
Joined
·
1,253 Posts
use an mbc+a on your car and you will be able to completely bypass the need for that expensive bpc.... i cant help u with this as i have a t7 car the guys with t5 cars and the mbc+a installed will help u greatly.... they will point u in the right direction... blue-93se can tell u where to get it
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #19 ·
Steve and Rico,

Okay, I disconnected my BPC valve by unplugging the 3 pin connector. No difference whatsoever in running or performance. Does this mean the valve is shot, or could it still be something else.

Steve, this valve is plastic, but has the more expensive part # 7485576. Any chance I can use the less expensive part (9175290)?

If there could be another problem associated with my base only boost situation, then Rico do you know anyone in Ct or nearby that might have a T5 9-3 or 900?

Tx
 
1 - 20 of 37 Posts
Top