Saab Link Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #1 ·
Right so im working on a friends 92 900S hatch. The car has been leaking water in the cabin and its been freezing here in Maine so all the carpets are frozen....So I brought the car to my garage and I couldnt turn the car off...turn the key to the off position and the lights turn off but the car wouldnt...so I jiggled the key and it eventually turned off but then my headlights wouldnt until I stepped on the brakes....and then whenever I hit the brake pedal the headlights turn on....I know its something with the ignition electrical etc...but has anyone else experienced this.....
 

·
Moderator
Joined
·
7,595 Posts
The ignition switch may be the issue. Likely this is due to the fact that the car has been leaking. It is also possible that the wiring that runs under the carpet is melting. Frequently, when leaky C-900's are in the final stages of their lives, the exhaust tunnel rusts through and the heat from the cat converter starts melting the wiring that runs to the ignition switch. There is a large pack of wiring that runs along the exhaust tunnel to the right of the drivers right leg
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #5 ·
This car has all of this plastic wire covers over the bundles of wires and all of that is in good condition as is the cloth over the cat bump... The rest of the car is so unrusty and in great condition. I cleaned out the sunroof drains and im gonna make it rain tomarrow while I sit inside the stripped interior to check for leaks.. I did find 2 holes in the floor but not until I poked around..Im also wondering if I have a source draining my battery because its been dead 2 times this week and the battery is about 1 month old..I put my meter on it and im getting 14V so idk..
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top