Saab Link Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,958 Posts
Discussion Starter · #1 ·
iam haveing an issue in the SPG and at the end of my ropes... iam getting a miss fire at about 3k rpm the tach just jumps up to 7k and the car back fires. what i have found online is that this is some kind of interferance. the car starts and idles like a dream, but the moment you stab the throttle and bring it up to 3k it just starts missing and back fireing. there are spark plugs in the car and it was running fine till it sat for a while and started doing this. its a V2.2 board running MsNS waste spark. i've checks and cleaned all the grounds. also another weird issue iam haveing is when i turn the car car off the injectors, main/fuel pump relays buzz and the only way to stop it is to unplug the MS. iam the end of ropes i feel like ive checked everything

thanks
 

·
Registered
Joined
·
419 Posts
Thats Megasquirt. I had it in my SPG and it was never right, then I installed it in my BMW and it was never right so I just sold the Megasquirt and went back to stock now that I can tune chips it works great. Megasquirt is originaly made to work for GM and FORD cars from 80s and early 90s.
 

·
Registered
Joined
·
4,702 Posts
could it be a coil pack issue? or something more on the hardware end instead of the MS ECU end??
 

·
Registered
Joined
·
5,805 Posts
ok, after a little researce with me running the Vr conditioner board i need to remove a bunch of stuff in the Ms unit, but i never removed it....so iam going to remove the stuff and move some wires around and hope for the best

Btw you need D5, R10, D8, C12, U14, C11, R11 removed
http://www.diyautotune.com/tech_articles/zeal_daughterboard_assembly.htm
Ahh, I was gonna mention that but didnt know the specifics for the 2.2 board. I had this issue with my 99 and the v3.0 board, it was set up for I think a hall sensor RPM input, and I was using the coil to get the RPM signal (still has points!) it wouldn't rev over 3krpm, way too much noise. I'd definitely give that a go and make sure you have the right schematic for the type of ignition input you are using.

Paul
 

·
Registered
Joined
·
1,958 Posts
Discussion Starter · #8 ·
hmmmmm makes sense technical the hall sensor stuff is still there but iam nervous to take all that out...
 
1 - 9 of 9 Posts
Top