Saab Link Forums banner

lc-1 db2 wideband problems

892 Views 5 Replies 4 Participants Last post by  saabskijc
ok so i have the innovate lc1 and digital db2 gauge set up in my car i had it working for about 6 months and now it works on startup and about twenty minutes later it will just go to 7.4 and flash the the led blinks 8 then takes a 2 second break and blinks 8 times again i dont even know where to start because it works fine on start up. oh and after it goes to 7.4 after 20 minutes of driving if you shut the car off for a second and turn it back on the gauge will work again any one have any ideas i tried posting this on the innovate forums but they are closed down
1 - 6 of 6 Posts
did you try recalibrating it?

sounds to me like either a calibration issue .... or a problem with the heater wire?

how close to the turbo is the o2 bung?? maybe you burnt out the sensor
mine did this also for a bit but it came out of it after i re calibrated it
lc-1's are great ... but require calibration often enough
Also try to update the LC-1 firmware and check reset the factory defaults. Had the same problem on my truck this weekend!
ill try recalibrate the 02 is a couple inches after the stock 02 after the first bend pretty much
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.