Saab Link Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,671 Posts
Discussion Starter · #1 ·
Yesterday I was merging onto the highway and I got on it a bit. When I did the red battery ligt came on, but turned off a few seconds letter. It came on again followed by "BING BONG" and the red triangle in the middle of the speedometer came on. Both turned off after a second or two. A couple seconds later the same happened again, but it stayed on this time so I pulled over. While this was happening I had my iPhone charging, vented seat on, radio on, headlights on but AC off. Once I was on the side of road both lights on the dash turned off. I shut everything off, except the headlights (DRLs) and unplugged my phone. Drove it to my shop (about 20 miles) and the battery light popped on just a couple times, but not the triangle. Got to shop with no problem, and no problem starting it again. Driving around today, it did exactly the same thing.

The belt is pretty old, and my first thought was the belt was slipping, but not really sure now. Sounds like its time for an alternator for me I guess? Probably not going to drive it this week.
 

·
Registered
Joined
·
1,671 Posts
Discussion Starter · #2 ·
Just had a thought. It might be a pulley seizing up? I know my AC compressor is bad, but the pulley has still been turning fine.
 

·
Registered
Joined
·
1,671 Posts
Discussion Starter · #3 ·
Just rolled up my windows (all four at the same time) with the car running and the dash became a Christmas tree. ABS, ESP, Brake, Battery, and triangle light came on, I got the "BING BONG" from the SID the Xenons dipped down, the interior lights dimmed and the windows went up very slowly. Everything went back to normal once I let go of the window switches. Sounds like it's time for an alternator.
 

·
Registered
Joined
·
3,604 Posts
you might get lucky and it's just the voltage regulator... but could well be the alternator. Do you have any whining coming from the engine bay? Mine was loud for a year or so before finally getting REALLY loud and crapping out.
 

·
Registered
Joined
·
1,671 Posts
Discussion Starter · #5 ·
you might get lucky and it's just the voltage regulator... but could well be the alternator. Do you have any whining coming from the engine bay? Mine was loud for a year or so before finally getting REALLY loud and crapping out.
I haven't noticed any extra noise, but I wasn't really looking for it. Didn't think about a voltage regulator. Can't find it on eEuro, do you happen to have a link to the part?

EPC is showing Part# 47-37-151 but I can't find it anywhere.
 

·
Registered
Joined
·
1,671 Posts
Discussion Starter · #8 ·
Ah, okay. Yeah if it were the Voltage Regulator I would still just go ahead and do the alternator anyway in that case. At 97k miles is about time anyway.

I don't have time to do this myself (I looked up the procedure on WIS...it's a bear on the V6) so I have appointment Monday at a local BMW/Audi shop to get it looked at. They're the only place I've talked to other than the dealer that would work on a Saab...
 

·
Registered
Joined
·
4,023 Posts
It's a little harder than a 4cyl.

You can pull the pass. drive axle out to make a little room.

Or you can pull the upper engine mount and with a big bar to move the motor enough to make room.
 

·
Registered
Joined
·
1,671 Posts
Discussion Starter · #11 ·
It's a little harder than a 4cyl.

You can pull the pass. drive axle out to make a little room.

Or you can pull the upper engine mount and with a big bar to move the motor enough to make room.
Yeah, I read up on the procedure in WIS. It called for removing the axle and shimming the engine forward. I have a long weekend coming up so I might give it a shot.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,671 Posts
Discussion Starter · #12 ·
Finally got ahold of the local Saab specific shop. Got a much better price on the replacement. Goes in on Thursday.

Sent from AutoGuide.com Free App
 
1 - 12 of 12 Posts
Top