Saab Link Forums banner
1 - 20 of 43 Posts

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #1 ·
I just got the damn 98 900 SE to quit stalling in mid range rpms, now its doing something else. Today it started running really rich (smoke out the tail pipe, woohoo), and I had to keep my foot in it to get it home. Just started doing that out of nowhere. Pulled the hose to the FPR, but that seemed to be free of gas, so I can't say for sure its the culprit. Just replaced a ton of parts on this thing, and it rewards me with this. It will run ok once its above 2k, but below that, its so rich it wants to cut out. Any help would be much appreciated, since I can't afford to keep screwing around with this thing. That and I need it to get to work, so bumming rides isn't exactly what I want to be doing, living 30 minutes out of town.
 

·
Registered
Joined
·
1,643 Posts
Wow, that's usually what happens when the BPC valve breaks and Shorts 12v back to trionic killing it, Mostly on 9ks though. Shake the bpc valve and see if it rattles back and forth inside, Or the di went to shit
 

·
Registered
Joined
·
287 Posts
Is it turbo'ed? If so do you have normal boost? Wish I could help more but my car is a totally different breed at times, no turbo, no balance shaft, so it doesnt match the US cars at all engine wise.
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #5 ·


Those plugs in the picture aren't even two months old. Granted, I should have changed them after my last issues caused stalling and such, but I figured maybe it could wait. Guess not. Besides them being nasty and filthy, what else should I be looking for?
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #6 · (Edited)
Tweek, thanks, but I can't get that far right now. I'm up near Round Hill, and without a way to get to Fairfax at the moment.

Unreal2004, it is turbo, and boost is as good as it usually is, provided its not trying to flood itself. Thats the worst I've EVER seen plugs in this car, even when I bought it from the previous owner.

Harvey's Autohaus, I'll try swapping DI's and see what goes on then. Its the original BPC as far as I can tell. For the record, shook it, no rattle inside. Is it supposed to? Not sure, as I've nothing to compare to. First T5 car.
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #10 ·
If the hose is off, That explains everything.
Nope, its there. This has turned out to be the most problematic car Ive ever owned. Starting to think another sucker needs to come along and take it off my hands once it runs enough to get off my driveway.

The only ecu I have around is out of a 96, and tuned for that car. I picked it up in hopes of tuning that one for mine later. Not sure that hooking it up would be of any benefit.
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #11 ·
Also noticed that upon slight application of the throttle, the rpms drop for a second and then catch up. With a rapid blip of the throttle, there is a small whistle from the BPV, which seems a little odd, as its holding boost like normal. Maybe its always been there and I never heard it, but the thing is still running rich, so I haven't bothered driving it.
 

·
Registered
Joined
·
859 Posts
edit* just realized its an auto


Butttt i strongly strongly advise you to clean your evap purge valve with electrical cleaner
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #14 ·
what color. how many doors. how many miles

im in the search for a good 5speed saab
Well I meant that comment only partly seriously. Right now, once it runs, its going to be my DD again. Wishing I'd kept the motorcycle, in spite of crazy northern VA drivers, so at least then I'd have had a backup. FWIW, its forest green, 5 door, 148k, but its auto so not as desirable.
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #15 ·
edit* just realized its an auto

Butttt i strongly strongly advise you to clean your evap purge valve with electrical cleaner
Evap valve is new, so thats not likely to be the issue. And when I say new, I mean new out of the box, and not yanked from a junker.
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #17 ·
How much Vac. do you have at idle?
Excellent question, but as I have no way to measure, I have no idea what the exact number would be. Not that its to be trusted, but the factory boos/vac gauge shows in the same spot it always does at idle.

Started it up a few min ago, and it seemed to run decently, but it still smells richer than it should be.
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #19 ·
Does your year car have a temp sender mounted in the delivery pipe like the T7 does?
Well are you talking about the intake temp sender on the bend right before the TB? If so, then yes its got temp sender. That's new. Basically every sender/sensor on this damn thing is as of the past month or two.
 

·
Registered
Joined
·
1,077 Posts
Discussion Starter · #20 ·
Is the BPC something that could affect the mixture like that? I'm not entirely familiar with all that it does.

Any way to test this, aside from unhooking it?

Gotta get fresh plugs tomorrow, but at the same time, I dont see how that will fix much since that is only a symptom and not the cause.

What else is there that would cause such a crazy rich mixture? I know, there's the coolant sensor, but thats not even a month old.
 
1 - 20 of 43 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top