Saab Link Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
yesterday while at a stoplight my TCSoff and check engine light came on at the same time, I noticed it felt like it wanted to stall, so I shut the AC off and the tach went to about 1700rpm.....at idle and stayed, when it should be at 1000rpm at idle?? So when I got home I decided to disconnect the battery just to see if it would cure the problem, well it did, the warning lights went out and the idle was back to 1000........ until this morning while on my way to work, this time I was not at a stoplight I was on the freeway and the TCSoff and check engine lights came on again at the same time, so when i got to a stoplight the idle was back at around 1700rpm....now this is were it gets weird, before the warning lights came on, the gas pedal had some resistance to it when I wanted to accelerate, so I reached down and checked that the floor matte was not in the way, it wasnt, it was as if the gas pedal was starting to stick and it was at that moment that I noticed the warning lights come on and the gas pedal no longer had the resistance to it, it was silky smooth......so I have absolutely nooooo idea?? BTW, this is happening to my 2001 Viggen :whacky044:
 

·
Super Moderator
Joined
·
6,726 Posts
Sounds like your throttle body is on its way out. How many miles?
 

·
Registered
Joined
·
1,339 Posts
You are in limp mode, look up T7 limp mode on you tube on how to fix. After you have reset limp mode, pull battery cable to see if codes clear.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #4 ·
thanks for the feedback.....I was able to reset the limpmode and cleaned the TB with some carburetor cleaner and disconnected the battery to reset everything, it has been fine since, but just to be on the safe side I had my dad take the TB off of my old engine that is sitting in his garage and send it to me, that TB is original to my car and has about 72k on it, the TB that I am running now from the replacement engine has about 134,000k on it......so it is prob. tinkering out.....Thanks again guys :)
 
1 - 4 of 4 Posts
Top