Saab Link Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
well my car is giving me headaches. first, the gage lights and dash lights dont come on. second, the head lights are really odd sometimes they work- then a few miles down the road- they turn off. third, the brakes shudder real bad when i stop. fourt, i have no boost! the gauge basically stays in the 12 o'clock area and occasionally go to th eleft a little. my SRS light is on, and my check engine light comes on and went off the other day- and is on again. - the shop i took it to cant hook it up to a diagnostic - who can?! :?: :!: :cry:
 

·
Registered
Joined
·
10,049 Posts
9000's are famous for failed headlights....
you need to get a new relay and perhaps the switch stalk too ($140 switch pack at my discounts.... lists for $272) the relays are cheap tho. about $20 should fix you right up - try the relay first however - cheaper too.


and there's some specialty Saab scan tool built to diagnose these things... so Dealer might be the only option there...
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #3 ·
burnsSide- you should get paid for being on this site.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #8 ·
i couldnt really see behind the turbo to see where the actuator was going- but i tried to reach back there and there was a part that i could move around easily.
:evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil:
does anyone know why my dash lights wouldnt be working????
 

·
Registered
Joined
·
5,805 Posts
robjunkins said:
i couldnt really see behind the turbo to see where the actuator was going- but i tried to reach back there and there was a part that i could move around easily.
:evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil: :evil:
You know that may be a good thing, its entirely possible that the wastegate actuator rod has just fallen off the turbo and thats why the wastegate is staying open. I think what i didnt make clear in the other post is that to check the WG you first have to take off a safety pin that holds the rod onto the turbo. So maybe you just need to put that rod back on and you'll be good as new :idea: .

Here's a diagram that i found that might help make this make more sense to ya:

now what im talking about is called something else there, the wastegate actuator is called the "control assembly" and the wastegate is called the "valve assembly" so basically the rod that connects the 2 has possibly fallen off.

good luck.

Paul
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #11 ·
oh - sweet! i will try to get in there tonight. man its a tight spot. i coild barely fit my hand back there. is it easier to jack the car up and go in from underneath? they definitly made it hard to get to thanks- that picture is worth a thousand wors!!!!!! :D
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #13 ·
I LOVE YOU GUYS! i just fixed the turbo- and HOLY S#IT!!!!!!!!! i am so so freakin happy. that thing ROCKS! thank you guys for the help - i would have bought a whole new turbo for nothing if it wasnt for your advise and directions. now i can booooooooooooooost :D
 
1 - 14 of 14 Posts
Top