Saab Link banner

1 - 20 of 24 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Sadly my 9-3 may have a blown head gasket? It started on Christmas Eve when I was driving in the thru way. It started running really rough. I thought it was a bad plug or a bad DI cassette but I replaced the spark plugs (with NGK's) and checked the DI by running lead from the neg batt terminal. All passed the test. Then moved to the throttle body and checked to see if it went to limp home mode. But it didn't. Finally I checked compression and discovered that I am getting no compression on the fourth cylinder. Blown head gasket or....? Before this all this happened it was giving me a code saying the thermostat sensor was malfunctioning. It was during a cold snap and my gauge was stuck for a day after it warmed up the gauge began working fine and I cleared the code. it didn't come back so I figured it was just a fluke.
During my diagnostics I have had a couple of odd codes like crank sensor malfunction (p0340 and p1334). Which made me think it was the DI. I consistently get P0304 (misfire on cylinder 4). Which is why I borrowed my buddies compression test kit. All other cylinders get 120+ psi.
Any one else run into this?
No oil that I can see in the radiator fluid.
No white smoke.
No fuel odor on the 4 cylinder spark plug.
Cylinder moves up and down.
No compression.
Any advice would be greatly appreciated.
 

·
Registered
Joined
·
5,988 Posts
Do you know if your crank-position-sensor has ever been replaced?

Although 0 compression in #4 is definitely a large problem.
 

·
Registered
Joined
·
3,270 Posts
Hows the oil look? No oil in coolant or coolant in oil and the HG is not the root of this problem.

I have my bet on a cracked valve or bad piston rings on cylinder 4.

What is you location?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Hows the oil look? No oil in coolant or coolant in oil and the HG is not the root of this problem.

I have my bet on a cracked valve or bad piston rings on cylinder 4.

What is you location?
I am located in Upstate NY near Albany. I agree. The more I think of it..The more I come to the same conclusion. Bad rings. The oil looks okay. No compression is bad news, no doubt.
Now I need to determine what to do with the motor. I could rebuild it... or swap it out with a junk yard engine. What a shame. My old 900 NG got over 240K and is still running. Of course thats a non turbo 2.3. Do the 2.3's have a better track record over all? Will a 9-5/viggen motor fit i the 02 9-3?
 

·
Registered
Joined
·
3,270 Posts
OG 9-3s have a CPS.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Thought it might not have had one must be the new 93's ...Could this be the cause of an engine failure on this level?
OR...Could this be the result of oil sludge?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Rebuild or new/used motor?

Has anyone rebuilt a '02 2.0 Turbo? Is it worth it? Im a little leery of a used motor because you never know if its been abused. Any advice? What Mods are best while rebuilding?
 

·
Registered
Joined
·
3,270 Posts
People have rebuilt plenty of these motors.

Are you willing to dig into this thing? Pull the head and take a look, It could just have a cracked valve and thats not as bad...
 

·
Registered
Joined
·
3,059 Posts
Have You tried squirting some oil into the cylinder and then doing the compression test?

If compression goes up, that points to your rings. However at 0psi I'm not sure that would really help ;)

The thing to do at this point would be a leak down test so that you can try to identify where your leak is. If you can't find a leak down tester you can always just hook compressed air up.

To do this make sure cyl 4 is at TDC and lock the engine there with a breaker bar on the crank bolt.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
I am going to crack it open this afternoon and look at the valves. In the end I may have to end up taking it to a shop. I really wish I had the time to really roll up my sleeves and dig into it. But the more I look into it the more I realize that this could take a month or more of wrenching it in my garage. Best I can do at this point is diagnose it and hope the repair price is kind.
This will probably end up costing me a few grand. It will definitely hurt. Im so disappointed. I have been into saabs and owned one or more for over 15 years now and no real major problems have ever surfaced engine wise. This was the last thing I expected. Quirks and minor stuff aside the saab has always been reliable. What a week! : saab goes out of business and then my engine flakes out. GM can suck it.
 

·
Registered
Joined
·
3,270 Posts
I know your pain, my car was doing great until it misplaced a few gears in the transmission last week.

Good luck.
 

·
Registered
Joined
·
616 Posts
my ng900 was doing the similar stuff ... i dunno about the codes though ... i changed heads ... and when i had my other head on the bench i checked to see if it would hold compression(mine was in cylinder 1) by putting water on it to see if it was sealing properly .. it wasnt ... bad valve seat

you should be able to figure out whats going on onbce you get the head off

GOOD LUCK!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #15
Well I checked it. I put a little oil in the cylinder and got no compression. So I decided to put just a little more in and got 3 PSI. I guess this a little good news all things considered.

I dropped it off at the shop after that. I hope to get a full diagnosis from this guys to confirm. If they quote me an astronomical number then I will take it back and try and do it my self on the evenings and weekends.

I will post the results from the shop and keep posting progress here. Maybe someone can gleam some information from this ordeal.

Im still wondering if this is engine sludge related.
 

·
Registered
Joined
·
85 Posts
3 psi isn't much. Sounds like a valve. Sludge wouldn't kill a valve. I'm in the albany area as well. Perhaps I could help you with it
 

·
Banned
Joined
·
3 Posts
A blown head gasket causes oil, exhaust gas, or cooling water to get into the wrong place. Usually water in the oil is the most common. The oil will look like chocolate milk. Some engines leak cylinder pressure into the cooling system. This pressure boils away and/or blows out the water thru the overflow tank. Your temperature gauge will fluctuate up and down, from what little water that's left circulating past the temperature sensor. Also, if you lower your rpm, the pressure decreases and allows the water to circulate correctly.

___________________________________________________________________
APEX PARTS Cylinder Head Gasket, 1.6L Eng., Fel-Pro# 9683PT-1
 

·
Registered
Joined
·
1 Posts
Its your coil pack. #4. Oil leaked into it prob. Either way change it. $50 takes 5 min... sorry for the 7 year later post lol. But this might help future people... not your head gasket. Syracuse NY
 

·
Registered
Joined
·
220 Posts
Its your coil pack. #4. Oil leaked into it prob. Either way change it. $50 takes 5 min... sorry for the 7 year later post lol. But this might help future people... not your head gasket. Syracuse NY
I think they already narrowed it down to no compression, which leaves either a broken valve, bad rings, or a destroyed piston. Nothing to do with coil packs. This generation did not have individual coil packs, only a DIC which is basically one coil pack that covers all four cylinders.
 
1 - 20 of 24 Posts
Top