Saab Link Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
10,049 Posts
Discussion Starter · #1 ·
So today I wanted to get the new Alpine head unit installed (by DeLorean) - replace my busted gauge cluster, change the valve cover and gasket, fuel filter, water pump and serpentine belt. Well - Head unit is in and looks/sounds great! Thanks Jeff! Gauge cluster is in - works good, cept the bulbs on the digital display are burnt out - guess my eyes weren't as good as I thought... and the new Valve cover and gaskets are on. Tomorrow I'll hafta do the pump and belt and filter. Here's some pics:










Needed more light to do the other jobs - but they will get done tomorrow. Then I'll need to change my oil later this week - it's looking rather blackish.... :roll:
 

·
Moderator
Joined
·
7,595 Posts
Looks good! A-1 wiring job on that head unit if I do say so myself :D solder and shrink tube is the way to go. I only mixed up one wire (constant hot / switched hot) cause the colors don't match, and I never bothered to check the leads on the 9000 with a multi meter. just switched em, problem solved. the CDA-9813 really is a nice unit. gets those Infinity speakers moving! expensive head unit, but WELL worth it IMHO. highly expandable.
 

·
Registered
Joined
·
1,140 Posts
nice dude

why do you have the walkie talkie mounted on your dash, do you drive around neighbor hoods, and wait for kids to be talking on them, then say random stuff in on their conversation?

~justin
 

·
Moderator
Joined
·
7,595 Posts
everyone uses those on saabmeets. it's your standard FM (I think...) 5 mile range unit. also, I think he just has it clipped on there, not "mounted" cause it was sitting in the console when I installed the head unit :arrow:
 

·
Registered
Joined
·
10,049 Posts
Discussion Starter · #5 ·
yeah - plus it picks up Comcast trucks (local cable co.) and other things from 309 and turnpike at times - fun to listen to. I need to fill that empty slot in the dash with a Police Scanner now ;) oh and the Digital display works PERFECT now - just needed some warm up time as I was thinking.
 

·
Registered
Joined
·
10,049 Posts
Discussion Starter · #7 ·
nah - the liquid crystals tend to need a "warm up time" if not used for some time. It was the same thing with the last cluster I installed - cept it was very dim to start with and gradually got brighter - and then the #'s filled in too.
 
1 - 7 of 7 Posts
Top