Saab Link Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I own a 2004 Saab 9-3. Recently I started having problems with the cooling system. My reservoir tank started overflowing due to high coolant temperature (not: car never overheated according to my temperature gage). I noticed that only one one my cooking fans was turning on. (Driver side fan) and it only came on when A/C was turned on. I took to mechanic and was told that one fan was bad and that relay fan control module was bad. Due to de module of the car I decided to buy a used cooling fan along with the control module. I was fortunate to test before buying and both fans worked perfectly fine on all speeds along with control module. Mechanic replaced the fans w/ module and went ahead and replaced coolant reservoir(new) and cooling temperature sensor (new). When I picked up the car everything worked fine. No overflow and both fans working properly. However after driving the car repeatedly, on the second day from repair I noticed that the passenger fan stoped working. My car doesn’t mark as overheating and one fan does come on. AC works fine by the way. Mechanic says it’s a bad passenger side fan since it’s used. But like I said I tested fans on car where fans where removed and both worked perfectly normal. I feel this is some kind of electric issue. Fuses and all are fine. Any have this type of issue. I don’t want to spend money on getting new fans and then something causes them to burn out somehow. If anybody could help I would appreciate.
 

·
Registered
Joined
·
2 Posts
Hi, I own a 2004 Saab 9-3. Recently I started having problems with the cooling system. My reservoir tank started overflowing due to high coolant temperature (not: car never overheated according to my temperature gage). I noticed that only one one my cooking fans was turning on. (Driver side fan) and it only came on when A/C was turned on. I took to mechanic and was told that one fan was bad and that relay fan control module was bad. Due to de module of the car I decided to buy a used cooling fan along with the control module. I was fortunate to test before buying and both fans worked perfectly fine on all speeds along with control module. Mechanic replaced the fans w/ module and went ahead and replaced coolant reservoir(new) and cooling temperature sensor (new). When I picked up the car everything worked fine. No overflow and both fans working properly. However after driving the car repeatedly, on the second day from repair I noticed that the passenger fan stoped working. My car doesn’t mark as overheating and one fan does come on. AC works fine by the way. Mechanic says it’s a bad passenger side fan since it’s used. But like I said I tested fans on car where fans where removed and both worked perfectly normal. I feel this is some kind of electric issue. Fuses and all are fine. Any have this type of issue. I don’t want to spend money on getting new fans and then something causes them to burn out somehow. If anybody could help I would appreciate.
That's really a sad news. One of my friends had the same issue. He consulted the certified technician and his issue was resolved.
Servicing Car
 
1 - 2 of 2 Posts
Top