Saab Link Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
My 1997 900S has intermitent gage and light functioning on the dash. Sometimes they work, sometimes the dash is dark..Does anyone here have some insight into the problem?..It was like this when I bought it..The engine runs fine..the only light that works every time is the "shift up" light. All of the external lights and signals work perfectly.
The PO wired a CD player into it..I am wondering if this may be the crux of the problem..Might a ground be disconnected?
TIA, zym
 

·
Registered
Joined
·
5,111 Posts
I think you have a few different things to look at.

#1. The rheostat that controls dimming.
#2. The SID which handles dimming in regards to ambient light.
#3. The connector to the guage panel.
 

·
Registered
Joined
·
104 Posts
#2

I have problem #2. My sid dimmer control turns my lights on the dash off. When you start the car up, you see the lights in the dash start at normal and then dim down to off. Do I have to replace the whole SID for just the dimmer issue or is there a way around it, rewire or repair?
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #6 ·
dash quirks

I think you have a few different things to look at.

#1. The rheostat that controls dimming.
#2. The SID which handles dimming in regards to ambient light.
#3. The connector to the guage panel.
Thanks for the start..the rheostat does not dim at all.I move it and it does nothing.
2..Will the SID keep the instruments from showing up as well? When the dash is dark, nothing is displayed..not speedo or tach needle movement..no milage is indicated, no temp or fuel needle movement..sometimes, the fuel milage-outside temp screen blinks and the dash lights up..it may work all the instruments for the entire time the car is running, then dosen't work after restarting the engine..hmm
3...where is the connector to the gague panel..I am thinking that is a great place to start checking things.
TIA, Howard
 

·
Registered
Joined
·
104 Posts
You may have something else, cable/connector electrical. With the SID dimmer problem, you'll see the dash briefly power up and then step down to off rapidly. Not all lights are off. Odometer light is on full bright. Some lights behind radio and SID display work.

All instruments should work fine. If you hit the black button on the SID then my instruments turn off. Hit again and my instruments turn back on, not the backlight, but the instrument itself.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #8 ·
Eagle eye..I think you are on to something there..Once in a while, when I turn the SID from black to on, the dashblinks and works..So I have to go under the dash and find the conector..or is it a case of taking the dash off and checking the condition of the connectors?
 

·
Registered
Joined
·
104 Posts
It looks to me like the SID has a major role in the control of the lights in the display. In my situation, I would need to check the wires and connectors in the SID, which I haven't done yet. That's my first point. if I can the the light sensor in the SID to respond normal, then I should be OK. Or maybe it a cable or connector in the SID. That's my first point. For you, this is a good starting point as well because I think the SID is the easiest thing to work on, connector and unit. Then, if all looks good, then you'd move onto the connector behind the display, unless you find this easy to remove.

I'm considering swapping a SID for a quick check. With prices, the cost of a second SID is maybe cheaper than the time to diagnose it. So, for my situation, I'm focused on the SID. I think it connectors or cables in the SID first. I'll let you know in about 2 to 3 weeks when I have a chance to work on it. Considering the problems with the sid display failing characters, I think this is the weak link. I haven't fixed the connector yet, that I know probably needs connector cleaning to restore. "SID display fix"

I think My manual dimmer control works fine and is not the issue. pulling electrical connectors, using electrical lube is always a quick fix/check.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #10 ·
sid

eagleeye..good call on the connectors..As mu SID is losing many bytes of info..and is working sporatacially at best, I will clean the connectors, put it back in, then go on and swap it with a known good one..Thanks.
zym
 

·
Registered
Joined
·
5,111 Posts
Wow... Oddly enough this just happened to me the other night. A light smack on the dash above the SID brought everything back up. I have a spare SID sitting around to try if it happens again.

I also recall reading something in the past about some harness that goes behind the SID and radio getting severed and shorting out. So perhaps that is also something to be checked out.
 

·
Registered
Joined
·
5,111 Posts
Swapped SID's... problem came back. Yanked out dimmer and fiddling with it made the gauges go in and out. Pulled the plug off and cleaned up the contacts a little bit and reseated it a few times. Seems ok now but I will be picking up a spare.
 

·
Registered
Joined
·
104 Posts
fixed dimmer rear dash light display

Ok, I got my (new) used SID for my '95 900s. I swapped it out and now my dash display works great!!! Dimmer works. that was the quickest fix ever. Just a quick swap and I'm good to go.

So, as with the pixels the bad cable connection inside the SID affects the dimmer and the dash lights. So, when I get around to it, i'll take the old SID apart and try to fix the cold solder joints connecting the cable to the board with an iron. I noticed the cable connector attaches the sensor to the main unit and that connection is probably what failed.
 

·
Registered
Joined
·
5 Posts
light at the end of a dark tunnel... I have written in many forums about this and just found this. I have had this center console blackout issue for almost a year now. I own a 2003 9-3ss (newer body). my gages behind the steering wheel work fine. my radio screen and SID screen come on fine. Its my buttons and knobs to control everything. The radio/ACC/power windows/radio controls on steering wheel=they turn on during the day and go off at night. If i start my car with a flash light shining on the dome above my SID it all lights up fine. once i shut off the light, it all goes dark. Had a tech2 reading, all tested fine lights turned on but once tech2 was unplugged, it goes back to dark at night. The mechanic didnt know what to do. Interesting enough I fiddled with my alarm settings. If i change it to "door alarm only" all my missing lights light up for about 60 seconds and then fade to dark again. so...SID issue? Tech2 programming issue? Rheostat issue? Time to get a new car because im always stuck with quarky probs in my saab issue?
 

·
Registered
Joined
·
104 Posts
Well, I'm no expert on the 2003 but it sounds like a cold solder joint/bad connection on your dimming circuit. It could be a bad cable connection or a cold solder joint somewhere. There is one other possibility. It could be a bad resistor/broken connection in the dimming circuit. It sounds like your shining the light causes a voltage response that turns the lights on. So it's kinda backwards. that usually means that your dimming circuit is not getting a supply voltage. So maybe you need a new SID for a quick fix. It may be cheaper with a used unit.

Is your alarm system original or aftermarket. If it's aftermarket, you have a problem with the alarm wiring that is tied into a sensitive wire that feeds into the dimming circuit. Aftermarket alarms will always tie into circuits that are now sensitive and can be damaged if not connected properly.

The Tech II is feeding a voltage back into your circuit causing it to work momentarily. This also relates to bad connection, cable or burned circuit somewhere around the SID.


On followup to my SID. My backlights burned out. They're very sensitive even on the bumping of removing and installing the SID. I swapped working bulbs around the two units to get it working again. What really bothers me is the ridiculous prices people want just for the bulbs. I'm ordering a bunch of bulbs I found on an electronics surplus supplier web site for way less than anyone else. I'll be ordering a bunch of different styles until i find the right one. Also, theres two sets of bulbs in each SID.
 
1 - 16 of 16 Posts
Top