Saab Link Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,998 Posts
Discussion Starter · #1 ·
As some of you know, I'm in the process of finishing my 1988 900 SPG. Well, we got it all together, but now it wont start. It has spark, and the fuel pump works, but the injectors arent opening. We tried different Jetronic boxes in it, and tested the original box in another car, and it worked in the other car. The box is recieving the signal from the distributor, and the box is sending the signal to the injectors, but the injectors arent recieving anything. So we've basically narrowed it down to between the ECU and the injectors. Also, the tachometer doesnt move when trying to start it.

Any ideas?
 

·
Moderator
Joined
·
7,595 Posts
there are 2 relays directly on top of the ECU. one is the fuel pump turn on relay, and the other is the jetronic turn on relay. my guess is that your ECU is not getting signal becuse it's not turned on (bad relay). you can also do a little trick here... if your fuel pump is not running you can jump the fuses, Ian (89saab900) knows which ones to jump, that will turn on the fuel pump via jumping these relays.
 

·
Registered
Joined
·
32 Posts
Just off the top I would run a wire from the ecu ground to the engine ground to the ground for the ignition amplifier (left wheel well). The injectors are grounded by the ecu. Look for positive on one of the two wires to each injector, with the ignition on but not cranking. If you have positive voltage its the ground. If you don't have a positive voltage then check the power relay and the continuity of the feed to the injectors. If not the ground then check for continuity between the injectors and the ecu.
 

·
Registered
Joined
·
71 Posts
just a thought, but make sure you have compression too. Also might want to make sure the ECU is seeing a crank signal......
 

·
Registered
Joined
·
71 Posts
nevermind with the crank signal, I need to learn how to read :roll: :p
 
1 - 6 of 6 Posts
Top