Saab Link Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1,180 Posts
Discussion Starter · #1 ·
on a 96 9k. the central locks will sometimes not go up or down from the switch or the outside. it still seems like it has power though because when it is not working and i try to unlock it, (unlocked or locked) it will make the sound like the doors are already unlocked. this does not happen all the time. sometimes if push the switch a bunch of times it will work again or sometimes it just works fine. 2nd, this may be the source of the issue idk, the drivers side lock tab (the black thing that you push down to lock the car) is really easy to pull up and down. almost like its not connected to anything, but i checked and it is. the others feel like they are normal, but the drivers side feels really easy to push up and down. also when i put the key in the drivers side door and turn it to lock or unlock, there is no spring back to original position like the passenger side door. 3rd, ill be getting a remote programed for the doors, do you think the car will still not unlock or lock sometimes from the remote? advice would be helpful. here is a vid to help http://s172.photobucket.com/albums/w8/kvnalb/?action=view&current=100_0370.mp4 incase you cant hear the sound at the end of me hitting the unlock switch and it making a sound, the sound is the same as if all the doors were on locked and you pressed the unlocked button.
 

·
Registered
Joined
·
13,686 Posts
I had an issue on my '95 9k that ended up being the central lock relay/brain. The issue started out minor, but got worse and worse. The symptoms were odd, and what you describe sounds similar, but since it was a few years ago I can't remember if it was exactly as you describe.
 

·
Registered
Joined
·
1,180 Posts
Discussion Starter · #3 · (Edited)
well took a look at things again and was able to figure out the drivers side door issue. turns out a spring is gone, causing the lock to me easily moved and such.
hard to see in pic but best i could do. its the one that goes inbetween the "z" piece where im pointing. im guessing ill have to pick up a used spring?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top