Saab Link Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
897 Posts
Discussion Starter · #1 ·
hi,

i finished putting my boost gauge in today and wanted to fire up the car. make sure it all worked etc etc.

car always needs a jump as i hardly ever start it since its an ongoing project. anyway hook the cable and turn the key to the ON position. everything looks good. lights on the dash come up car starts beeping cause the doors open.

push the clutch in turn the key and nothing. car doesnt even try to turn over or crank. all i hear is a POP like noise. after that all the lights go out and when i put the key back to the ON postition nothing lights up its like the car has no power.

take the cables off and repeat. same thing happens. i do this for like 15 mins no luck. as soon as i turn the key to ignition i hear a POP (thats the only way i can describe it) and then nothing will happen until i remove the cables and put them back on the battery.

any ideas? i powerwashed the suspension/steering rack area from the side yesterday. could i have hurt something? please help me out.

thanks guys

-zach
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #2 ·
nevermind. i got it working. pulled the neg battery cable and let it sit 20 mins and when i tried jumping it again it fired right up. idk. this car is something else. lol.

any ideas on my boost gauge thou? it wasnt reading anything at idle. is this normal? im guessing i have to be in gear for it to make boost right? not just revving the engine.

the light on the gauge came on via the dimmer which is what i spliced into. really happy bout that.
 

·
Registered
Joined
·
4,789 Posts
It should read vaccuum pressure at idle(should be around 16-22hg, is the norm)
nevermind. i got it working. pulled the neg battery cable and let it sit 20 mins and when i tried jumping it again it fired right up. idk. this car is something else. lol.

any ideas on my boost gauge thou? it wasnt reading anything at idle. is this normal? im guessing i have to be in gear for it to make boost right? not just revving the engine.

the light on the gauge came on via the dimmer which is what i spliced into. really happy bout that.
 

·
Registered
Joined
·
1,487 Posts
lol yes but the other gauge will so how much your not making when you have a vacuum leak ;) i have one thats good for 30psi and have vac up to i think 30hg
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #8 ·
lol yes but the other gauge will so how much your not making when you have a vacuum leak ;) i have one thats good for 30psi and have vac up to i think 30hg
yeah thats nice but im not worried bout it really. i can tell if the car has a vacuum leak dont need a gauge for that. lol.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top