Saab Link Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
10,049 Posts
Discussion Starter · #1 ·
OK - it started Friday night when I was sitting with my hazzards on - then I noticed the switch was on - but the lights had stopped flashing. I figured it was just a gremlin so I tried the switch a few times and nothing happened - lights still worked - but no turn signals or hazzards. Well - the fuse turned out to be blown. OK - no biggie I figured - I pull my Fog Light fuse out and pop it in - turn on the signal - POP! - blew the fuse. Tried it again today and it's eating fuses on the hazzard and the turn signals. I noticed the LEFT (drivers side) corner lamp has more of my favorite Frayed wires - could these be the cause? Anyone have an idea? I need to get these things functioning again. Anyone have a good wiring diagram of an 87 9000 Turbo? (and can explain it) Thanks :shock: :roll:
~BurnsSide42~
 

·
Registered
Joined
·
5,805 Posts
BurnsSide42 said:
I noticed the LEFT (drivers side) corner lamp has more of my favorite Frayed wires - could these be the cause? Anyone have an idea? I need to get these things functioning again. Anyone have a good wiring diagram of an 87 9000 Turbo? (and can explain it) Thanks :shock: :roll:
~BurnsSide42~
well yeah id say it would most likely be youre ancient wiring harness thats the issue, after all the fuses are there so you dont set your car on fire with that shit :roll: :lol: . might wanna try re-wiring it.

Paul
 

·
Registered
Joined
·
10,049 Posts
Discussion Starter · #3 ·
yeah, but you see - I don't DO electrical yet... it's not my forte' ya know - not yet anways. I can splice shit - I just suck at running new stuff cause Saab made it impossible to run it where it needs to go..... :roll: Plus i have no idea where shit runs on this car... :!:
 

·
Moderator
Joined
·
7,595 Posts
that would be my advice. if a fuse is blowing instantly when you put it in, that means that a wire is shorting to ground. yes, the fuse is doing what it should in that it's prefenting the whole car from burning down.
 

·
Registered
Joined
·
10,049 Posts
Discussion Starter · #7 ·
Ok - so last night I was bored and decided to start on the 9000's problem - This is what I found:
Harness was soaked in water, and sitting with water in the casing - rotted, and dissconnected at some parts.
DeLorean came by on his bike - and with the harness I had gotton from the yard this week he Temp. Fixed it - We will do shrink tubes and sodder tomorrow to ensure lasting and proper function for long time.

Before Pics:




Now the lights all work as they should and no fuses are being shorted out - but I'll hafta finish this up tomorrow to ensure it doesn't happen again.

Also found that my rear tire well molding has separated from the car... the Rot has gone up another level on the drivers side.... Damn Car always has something ..... :roll: :evil:
 

·
Moderator
Joined
·
7,595 Posts
yeah, easy fix. the wires at the end had all the insulation fall off of them and were touching. you should look into getting a patch panel welded in or something. there needs to be SOME metal there to make it work, bondo can't stick to nothing. later on I guess...
 
1 - 8 of 8 Posts
Top