Saab Link Forums banner
1 - 20 of 21 Posts

·
Registered
Joined
·
8,796 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
10,049 Posts
I have a 1999 9-3 Gauge cluster with like 112K on it - works fine - can not recall if it will work on a ng900 (I would think yes) I paid $100 for a replacement thinking I needed a new MIU - would take $50 plus shipping for it.

I also think I have a NOS grill in my parents basement - Would take $50 shipped if it is NOS and still there. If it's a 9-3 grill same price.
 

·
Registered
Joined
·
8,796 Posts
Discussion Starter · #6 ·
ill wait and see jeff. the cars got what is described as "a gauge cluster that wont light up".

havent gotten a chance to look at it yet, so it could just be a fuse or something, but i have a feeling it may be one of those rare failures or something.
 

·
Registered
Joined
·
130 Posts
My '95 900 SE vert is getting parted out in the next week.

Here is a link to the car's condition, along with Twitter updates to my schedule: 1995 NG 900 SE 4-cyl Turbo vert

I also have a bunch of other parts from a part out last year.

Might even be able to meet in the Glens Falls/Albany area.
 

·
Registered
Joined
·
8,796 Posts
Discussion Starter · #13 ·
yeah cousin picked up a cheap ass car without asking me, has a ton of issues.

personally i would have run away from a car claiming to have wiring issues, especially a dead gauge cluster.
 

·
Moderator
Joined
·
7,595 Posts
aah, well those bulbs do go out, it may simply be that. my 9-5 lost all the cluster lights, one bulb at a time. Replace them, and it might be just fine. If it's not that, it's probably the rheostat on the dash. Either one should be a fairly easy fix.
 

·
Registered
Joined
·
8,796 Posts
Discussion Starter · #15 ·
yes, gonna try all the logicals first, the seller also listed it as a wiring problem with the headlights because they are on all the time, and i do believe these had drls (95 900)

owned by a female obviously...

im sure i will need more troubleshooting help soon.
 

·
Greek Mod
Joined
·
4,294,967,295 Posts
ill wait and see jeff. the cars got what is described as "a gauge cluster that wont light up".

havent gotten a chance to look at it yet, so it could just be a fuse or something, but i have a feeling it may be one of those rare failures or something.
probly needs a rheostat switch is all, either that or like delorean said just needs bulbs
 

·
Registered
Joined
·
913 Posts
probly needs a rheostat switch is all, either that or like delorean said just needs bulbs
Yeah, my rheostat was bad. Try changing that first, it's easier than pulling the cluster and changing the bulbs.
 

·
Registered
Joined
·
3,061 Posts
ngs do have GMs twilight sentinel which allows the headlights to stay on for a short period of time after exiting the car so you can get to your front door or whatever at night.
 

·
Registered
Joined
·
8,796 Posts
Discussion Starter · #20 ·
Ha ha - Lights stayed on all the time. Nice - or do they when you shut the car off act like they are on a timer? My mom used to claim her 97 ng900 did that - however I never whitnessed it...
owner said only on while running aka DRL's even said she figured out how to pull a relay under the hood when she wanted them off.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top