Saab Link Forums banner

1 - 10 of 10 Posts

·
Administrator
Joined
·
668 Posts
Discussion Starter · #1 ·
so im getting on the interstate the other day and my car makes a sort of sputter... the turbo quits boosting and the cars CEL is flashing. I get off the road and check to make sure all turbo hoses ETC are connected and nothing is broken... when i start the car back up the CEL is still on and when ever i boost into turbo the car basically slows down... back on the interstate the car runs for another few miles then shuts down totally. the car will crank and start for a second but thats it. I had the car towed to a dealership where they tested it and when i called back today they said the car was "over boosting" so the ECU went into a basic boost mode and shut down, they then told me that they had reprogramed the ECU and it should be ready this afternoon... seing as A) I asked them to call me before they did anything and B) I dont see how over boosting could cause this.....

What do you all think is wrong and what do you all think i should do?
 

·
Trollerator
Joined
·
9,830 Posts
aren't they supposed to give a price quote before doing the work?

I didn't think they were allowed to do anything without asking first. :!: :!: :!: unless you brought it to them and said "just fix it!" :?: even then I have always had the stealer (even at the BMW stealer) give me a quote and tell me what parts/labor were involved before they would touch anything!

I don't know too much about mechanical stuff by why would the ECU "all of a sudden" not work right and the dealer can magically fix it? :shock: :? if the ECU went into basic boost or limp home, wouldn't it be some hardware failure that caused that? like a faulty boost solenoid or something making it overboost?
 

·
Administrator
Joined
·
668 Posts
Discussion Starter · #3 ·
thats what i said... i was like yeahhh the ECU does not just do that... and she was like i dont know they just had to reprogram the turbo... and GERR i hate talking to stupid people... just like WTF reprogram the TURBO!?? WHAT!? so yeah I dont know they dident call me and they did not ask so if its more than like 100$ im telling them to kiss my ass. but what im trying to figure out is what exactly went wrong and how they fixed it by "reprograming" the turbo
 

·
Administrator
Joined
·
668 Posts
Discussion Starter · #4 ·
as far as making it over boost... the new FPR could have something to do with that... but ive been driving for weeks with it on there... plus the T7 should just compensate for an "over boost" it should not cause the car to shut down or anything like that... should it?
 

·
Trollerator
Joined
·
9,830 Posts
If I understand what i have read here, resetting the ECU will clear limp home mode but as soon as the hardware acts up again, it will throw another CEL and come back. So you gotta fix the hardware to really fix it.

I have read that if your boost solenoid goes bad you could have wild, uncontrollable boost, maybe the cause of the "overboosting"... so the engine throws a CEL and goes into limp home mode. I think those solenoids only cost 44 bucks.

I'm sure someone else who knows more about the mechical stuff will have some ideas for you, too. :wink: good luck with the stealer.
 

·
Trollerator
Joined
·
9,830 Posts
Boxerchip said:
as far as making it over boost... the new FPR could have something to do with that... but ive been driving for weeks with it on there... plus the T7 should just compensate for an "over boost" it should not cause the car to shut down or anything like that... should it?
is this your new maptun ecu, did that ever get fixed? If the chip inside is not soldered in good, and it got loose, it could "shut down" I suppose, more to do with the TWICE/security system. Or if you are running stock software with an uprated FPR could that be a problem? I don't know how that would work.
 

·
Administrator
Joined
·
668 Posts
Discussion Starter · #7 ·
this is stock ECU with a FRP but it should not cause any troubble... the thing is that its not just in "limp home" mode its SHUTTING DOWN!
 

·
Registered
Joined
·
745 Posts
You mentioned your CEL flashing, did you happen to count them? They should tell you where to start looking. But I'm sure the dealer put their analyzer on it.... But reprogramming the ECU....sounds a bit drastic. :shock: Why not reset?

The overboosting...sounds relative to boost control, wouldn't have thought the ECU caused more boost when...seeing more fuel. But more likely, more boost is compensated with more fuel..and not the other way around. Perhaps seeing the rich mixture your ECU is cutting the fuel....leading to needing more boost to move the car. Caught up in a vicious loop.

I'd reset the ECU, install a stock FPR until your new ECU arrives....(if that was the justification for having the larger FPR).

I hope you didn't have Maptun problems on your car too. Guessing the larger FPR was for a stage4 -5 application.

hope you find it soon ....really curious to learn more.

Good Luck
 

·
Registered
Joined
·
745 Posts
Vigge made mention that bigger FPR tends to mean better Fuel Pump needed...any chance your pump went bad?

a thought
 

·
Registered
Joined
·
51 Posts
DC_SAAB said:
Vigge made mention that bigger FPR tends to mean better Fuel Pump needed...any chance your pump went bad?

a thought
Time for a fuel pump pressure test!

Mr Green, did you ever get this problem fixed ??

IMO, modifications are not a good idea, lead to troubles - why "gild the lily" ??
 
1 - 10 of 10 Posts
Top