Saab Link Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2,754 Posts
Discussion Starter · #1 ·
Blower works in all ranges. Blending door works. It has tremendous heat on high in auto and econ. No heat at any other temp setting. ISAT says fault code 26391- Outside temp sensor but that is there and it is working.
 

·
Registered
Joined
·
2,754 Posts
Discussion Starter · #2 ·
Now it is not showing the original code, it's showing permanent fault 42521-Blended air interior temp sensor short circuit to battery +

Does this just mean the sensor is bad or is there an actual short in the wiring?
 

·
Registered
Joined
·
2,312 Posts
I just had the same issue with mine. A new interior temp sensor fixed it.
 

·
Registered
Joined
·
2,754 Posts
Discussion Starter · #4 ·
By that you mean cabin fan sensor? I replaced that and nothing changed with the ACC that was in there. When I changed the ACC AND used the new fan sensor, it worked. By themselves they wouldn't. I'm still getting an interior air blend sensor fault, but at least it has heat now.
 

·
Registered
Joined
·
2,312 Posts
Something happened when my interior cabin temp fan sensor (the one below the heated seat switches) bent bad. I think it fried my acc in the process because the sensor started making noise, and as soon as the sensor quit completely, the acc set itself to full cold with A/C on high. It would not respond to any functions including off. It still did this even after installing the new sensor. I had to change to a different acc before everything started working again.
 

·
Registered
Joined
·
2,754 Posts
Discussion Starter · #6 ·
Yep, very similar story. Thanks.
 
1 - 6 of 6 Posts
Top