Saab Link Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
465 Posts
Discussion Starter · #1 ·
the pump works fine and the injectors are pumping but everything else is dry..what can it be?
 

·
Registered
Joined
·
5,805 Posts
the pump works fine and the injectors are pumping but everything else is dry..what can it be?
If you aren't getting fuel to the rail, the pump isn't working, either its not pumping any fuel, or its not being turned on by the ECU/fuel pump relay. If you bypass the fuel pump relay and power the pump directly do you get fuel at the rail?

Paul
 

·
Registered
Joined
·
465 Posts
Discussion Starter · #3 ·
i do have fuel to the rail it's not going into the cylinders the plugs are dry..
 

·
Registered
Joined
·
1,030 Posts
How do you know for sure that the injectors are firing? Pull the rail off and try turning the engine over...see if fuel shoots out (use caution ;))
 

·
Registered
Joined
·
465 Posts
Discussion Starter · #5 ·
gas isn't getting into cylinders because the plugs are dry, and when i loosened the fuel rail nut gas is coming out. I think something isn't letting the gas release through the injectors
 

·
Registered
Joined
·
50 Posts
"87 c900 not getting fuel to injectors" - means you are not getting fuel at the rail.

Perhaps you meant fuel is not getting through injectors instead. So, it cranks but does not start and plugs are dry? My E30 had this when there was no power to the main relay. Pump still worked, but no ignition and no fuel.

Make sure you are getting power to the main relay.
Any fault codes?
What did you do to the car before?
 

·
Registered
Joined
·
4,702 Posts
check the FPR, and the fuel pump, sometimes lines split inside the fuel pump houseing,

also check for an injector pulse from the harness
 
1 - 8 of 8 Posts
Top