The Saab Link Forums

The Saab Link Forums (https://www.saablink.net/forum/index.php)
-   Performance Modifications for the NG900 / Old 9-3 (https://www.saablink.net/forum/forumdisplay.php?f=24)
-   -   Intake Rev. 5 installed (https://www.saablink.net/forum/showthread.php?t=2132)

CO-Saab 09-21-2004 08:50 AM

Intake Rev. 5 installed
 
I have rev. 5 of my intake installed and pictures posted on my site. Every metal pipe in the car is ceramic coated. I will have a rev.6, it will change the silicone intake elbow to a different profile (and color) allowing a less restrictive path to the turbo. If you enlarge the last pic on page five you can see the kink in the elbow. I already have the replacement, just waiting for time to install. Enjoy!

Blaque 09-21-2004 09:32 AM

Wow. That is look VERY nice. What numbers are you putting out? What did all the Jet Hot coating run?

CO-Saab 09-21-2004 10:49 AM

Ced,

Thank for the compliment. Numbers are still unknown, but it is powerful. It's not running completely right. I'm missing about half a BAR of boost. :shock: I still have a check engine light that won't go away. I've replaced every component on the loop the ECU says has a problem. At this point I think it is a problem with the ECU. (Frank won't admit he might have made a mistake :wink: ) I'm waiting on Kevin Yankton to piece his beast back together. When he is ready for the software tune Frank will visit both of us in the same trip. I'd rather not continue this waiting game, but understand he's a busy man.

Let me assure everyone, the day after the software tune is final, I'll have dyno sheets on my site! I am more interested in the shape and amplitude of the torque curve than the max attainable HP.

snow4_1man 09-21-2004 11:02 AM

Hey nice work on your car everything looks awesome. Do you have any info the Intercooler?

DC_SAAB 09-21-2004 11:18 AM

Cool setup..., and you actually have those larger injectors installed too?....nice.
Any chance your CEL comes on for running a little rich, or having your O2 mounted too close to the initial exhaust out the turbo.

I just happen to notice where its mounted..., as they are typically mounted closer to the front of the CAT. Perhaps where its at now, might be causing enough of a difference on O2 Sensor 1 and 2 to cause a CEL.

Hope you find the problem and dyno soon.

regards

CO-Saab 09-21-2004 11:54 AM

Quote:

Originally Posted by DC_SAAB
Cool setup..., and you actually have those larger injectors installed too?....nice.

Yep, they've been in since ~January.

Quote:

Originally Posted by DC_SAAB
Any chance your CEL comes on for running a little rich, or having your O2 mounted too close to the initial exhaust out the turbo.

Nope, I've had that exhaust on the car for three years, never had a problem with the location of the O2 sensor on any of the ECU's I've tried. I've had alot, all but this one were returned for other reasons. I used the stock ECU until I changed the injectors and FPR, then I needed the custom ECU.

I've seen a rich CEL a few times over the last few months, but I'm not too concerned. It's probably due to the perceived boost leak.

The CEL bounces back and forth on the evap. system. Sometimes it's the canister sometimes the purge valve. Totally not related to engine strength, in fact, the car won't limit power b/c of evap system problems. I think I'm loosing power with a boost leak between the TBTC and block. Don't ask how just yet, it has to do with the intake manifold mods, Qin=Qout, the engine only wants so much air....... I'll get to the bottom of it. Thanks for your concern, I'm all ears for possible resolutions to my woes.

noxben 09-21-2004 01:26 PM

very nice work. i only wish i could get anywhere close to that kind of work done on my saab. fortuneately for me there are people like you and kevin and eric that i can gauk over. :shock:

well done!

Ben Y.

roadkil34 09-24-2004 06:27 AM

out of curiosity, what type of gauges are those? and what type of dual mount is that? thanks

-Frank

CO-Saab 09-24-2004 12:42 PM

Gauges are Apex'i. EGT is 403-A019 and the boost I settled on is 403-A042
A word of caution, these gauges are 60mm and will require custom A-Pillar pod as most are made for the standard 52-mm gauges.

CO-Saab 09-30-2004 01:11 PM

Quote:

Originally Posted by DC_SAAB
or having your O2 mounted too close to the initial exhaust out the turbo. I just happen to notice where its mounted..., as they are typically mounted closer to the front of the CAT.

DC, looking at the stock exhaust I have in the shed this O2 is mounted in the exact same place as stock. Could this be another difference on the '99 HOT?


All times are GMT -8. The time now is 05:19 AM.

Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.