Need Help with My New Stage 3 ECU - The Saab Link Forums

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Performance Modifications for the NG900 / Old 9-3

Performance Modifications for the NG900 / Old 9-3 This forum contains PERFORMANCE related Q&A's for the NG900 and 9-3. This may also include suspension.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-28-2005, 02:34 PM   #1
TSLMember
 
Join Date: Mar 2004
Location: Griswold, CT
Posts: 62
Need Help with My New Stage 3 ECU

Just installed my new Maptun Stage 3 ECU for my 1999 9-3. Power has increased but feels only like a stage 1. I have all the necessary mods for the stage 3 (3" DP, Vig IC, 2.5" cat back, Vig BPV, etc.). My concern is, and I am assuming it is my car and not the software, that when I floor it, the stock turbo boost guage travels only halfway into the yellow. This mirrors the boost pattern for my stock ECU. Shouldn't the stock boost guage be pinned int the RED?. Any help would be much appreciated!
Slaaby Seconds is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-28-2005, 02:36 PM   #2
SAABeginner
 
Join Date: May 2004
Location: Newark, Delaware 97 900 SET
Posts: 20
Send a message via AIM to roadkil34
You dont have a MBC in there, do you? Just a thought. Also, check your BPV. That could be the culprit.
roadkil34 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-28-2005, 02:50 PM   #3
Flirting With TSL Addiction
 
trexturk's Avatar
 
Join Date: Oct 2003
Location: Schaumburg, IL
Posts: 729
Send a message via AIM to trexturk
you also might have a boost leak in one of your pipes.
just a thought.

Also take it to the dyno to see if the HP is accurate with the stats
__________________
Now: 04 Nogaro S4
Past: 99 Stage 4 9-3
trexturk is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
 
Old 01-28-2005, 03:38 PM   #4
HNNLIC
Elder
 
Blaque's Avatar
 
Join Date: Oct 2003
Location: Washington, D.C. / Kansas City
Posts: 4,209
Send a message via ICQ to Blaque Send a message via AIM to Blaque Send a message via MSN to Blaque Send a message via Yahoo to Blaque
It should be definately boosting into red.

I'd give them a call about it.
__________________
Virtualization FTW. IT 4 Life.

“Brothers and sisters… and friends…and I see some enemies. In fact, I think we’d be fooling ourselves if we had an audience this large, and didn’t realize that there were.. some enemies present.” –Malcolm X


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Blaque is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-28-2005, 04:18 PM   #5
Flirting With TSL Addiction
 
xaamottomaax's Avatar
 
Join Date: May 2004
Location: Washington, DC USA
Posts: 475
You should be boosting more than that with your stock ECU. There is probably a leak somewhere or a faulty valve as suggested if both ECU's are getting to the same point (on the stock boost guage) and then dying.
xaamottomaax is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-28-2005, 06:22 PM   #6
Flirting With TSL Addiction
 
DC_SAAB's Avatar
 
Join Date: Feb 2004
Location: Washington DC
Posts: 739
Send a message via Yahoo to DC_SAAB
My stage 3 Maptun had me boosting just above the red.. but I have a t5. Are you running a t7? Cause I'm not sure you would see into the red like you do on a t5. Any chance you installed a real boost gauge to see if any difference between stock and Maptun?

I had a vacuum line that had a hole in it near the base of my throttle body, but still managed to peg the boost needle. I noticed a change when I turned off my climate control. I mean very noticeable. But I also kept my stock ECU just in case of a problem, or return on the product was required.

good luck..
__________________
DC
DC_SAAB is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 05:08 AM   #7
Live, eat, and sleep by TSL
 
ricot83's Avatar
 
Join Date: Jun 2004
Posts: 1,253
Send a message via AIM to ricot83 Send a message via MSN to ricot83
install a real boost gauge.
ricot83 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 10:30 AM   #8
TSLMember
 
Join Date: Mar 2004
Location: Griswold, CT
Posts: 62
OK, first of all thanks for all the input!

Roadkil - I do not have a mbc.

Trexturk - Exactly what pipes are you talking about?

DC Saab - My 9-3 is also a T5

Has any one experienced a symptom before where boost was ok but just stopped at a certain point and held there. I don't have any spikes at least from what I can tell from my stock boost guage. My BPV is the upgraded bosch BPV. Would that stop me from reaching max. boost compared to an aftermarket valve?

If it is a vacuum line would boost problems be similar to what I am currently seeing?

If it is a loose IC pipe, would that be consistent with what I am seeing?

Could it be my wastegate?

Just trying to isolate this before I go buy all new pipes, lines, and valves. Keep the input coming I welcome all!
Slaaby Seconds is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 12:21 PM   #9
Trollerator
Elder
 
abdukted1456's Avatar
 
Join Date: Feb 2004
Location: Albany, NY area
Posts: 9,830
I have a Maptun stage 1 (T7) and I go well into the red. Sorry, no boost guage yet so I can't give you a number for boost psi. just an fyi, for t7 stage 3 is only like 10 HP more than stage 1, it is more about better top end power and breathing than a massive peak HP gain. not familiar with the t5 upgrades, though.

Did you try unpluggin the Boost solenoid thing and see what happens. this is a easy way to see if the solenoid is working, right? you should get base boost, halfway into the yellow/orange... if you get wild crazy uncontrollable boost then it is not working. Someone correct me if i am wrong.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1990 900 turbo vert
2004 9-5 aero sedan
abdukted1456 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 12:22 PM   #10
Trollerator
Elder
 
abdukted1456's Avatar
 
Join Date: Feb 2004
Location: Albany, NY area
Posts: 9,830
p.s. I would get a hyperboost HX BPV or a forge BPV or blow off valve.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1990 900 turbo vert
2004 9-5 aero sedan
abdukted1456 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 12:36 PM   #11
TSLMember
 
Join Date: Mar 2004
Location: Griswold, CT
Posts: 62
Abduckted,

That's exactly where it is halfway between the yellow/orange. It sure feels like I'm only getting base boost. Can you direct me to where the boost solenoid is?
Tx.
Slaaby Seconds is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 01:26 PM   #12
Elder
 
stevehayes01's Avatar
 
Join Date: Nov 2004
Location: Jacksonville, Florida
Posts: 3,976
Send a message via AIM to stevehayes01 Send a message via MSN to stevehayes01 Send a message via Yahoo to stevehayes01
My car had very similiar experiences but then it flipped to the opposite and I was pegging the top of the red in every gear and I didnt have a reprogrammed ECU!! IT turned out to be my Boost Pressure Control valve and now all is well.

Right side of the car next to the Radiator and is a metal 3 hose barb device. On a T5 it is a fairly expensive piece to replace so you want to find someone close to you with a good working T5 and swap with them and see if the issue goes away or not. If it does then you know thats the issue and you can goto http://thesaabsite.com and get it fro like $200 or so.

93 99-03 Boost Control Valve B204 Engine only NOT VIGGEN
OES 7485576 $ 215.00

or if you are lucky you have the plastic valve located near where the other one is but on the block side of the engine bay intead of on the radiator.

93 99-03 Boost Control Valve B205-B235 Engines
OES 9175290 $ 44.00
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

stevehayes01 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 02:29 PM   #13
Live, eat, and sleep by TSL
 
ricot83's Avatar
 
Join Date: Jun 2004
Posts: 1,253
Send a message via AIM to ricot83 Send a message via MSN to ricot83
instead of buying a bpc i would try a boost controller... then u will know if it is the bpc or if in fact your car is in limp home mode... also try a new bpv.... and i wouldnt make a conclusion just by what your stock gauge says as it has been said many time shtat this is subjective... my car has hit 14 psi b4 and the stock gauge only says its 1/4 in red i believe.. i dont even look at that gauge anymore
ricot83 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 08:17 PM   #14
TSLMember
 
Join Date: Mar 2004
Location: Griswold, CT
Posts: 62
steve and Ricot,

Thanks for the input I'll look into it. Unfortunately, I have the 204 Engine. But if that's the problem it makes sense to correct. Any way to check the Boost Pressure Control Valve without replacing it first?
Slaaby Seconds is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 09:26 PM   #15
Live, eat, and sleep by TSL
 
ricot83's Avatar
 
Join Date: Jun 2004
Posts: 1,253
Send a message via AIM to ricot83 Send a message via MSN to ricot83
use an mbc+a on your car and you will be able to completely bypass the need for that expensive bpc.... i cant help u with this as i have a t7 car the guys with t5 cars and the mbc+a installed will help u greatly.... they will point u in the right direction... blue-93se can tell u where to get it
ricot83 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-29-2005, 09:46 PM   #16
Elder
 
stevehayes01's Avatar
 
Join Date: Nov 2004
Location: Jacksonville, Florida
Posts: 3,976
Send a message via AIM to stevehayes01 Send a message via MSN to stevehayes01 Send a message via Yahoo to stevehayes01
Wouldnt yu want to keep the BPV installed with the Stage 3 ECU? I would think that you would be doing a diservice to the new chip to install a MBC+A to it. I really think that you ought tosee if the BPV is the culprit before you add anything else to the system. Just my 2 cents.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

stevehayes01 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-30-2005, 07:07 AM   #17
Live, eat, and sleep by TSL
 
ricot83's Avatar
 
Join Date: Jun 2004
Posts: 1,253
Send a message via AIM to ricot83 Send a message via MSN to ricot83
that is very true... i think i may have said that like 10 posts up and no one paid attention as usual.....
ricot83 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-30-2005, 10:42 AM   #18
Elder
 
stevehayes01's Avatar
 
Join Date: Nov 2004
Location: Jacksonville, Florida
Posts: 3,976
Send a message via AIM to stevehayes01 Send a message via MSN to stevehayes01 Send a message via Yahoo to stevehayes01
Sorry to not pay attention to you as usual!!!! Wait what did you say again???
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

stevehayes01 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-30-2005, 11:54 AM   #19
TSLMember
 
Join Date: Mar 2004
Location: Griswold, CT
Posts: 62
Steve and Rico,

Okay, I disconnected my BPC valve by unplugging the 3 pin connector. No difference whatsoever in running or performance. Does this mean the valve is shot, or could it still be something else.

Steve, this valve is plastic, but has the more expensive part # 7485576. Any chance I can use the less expensive part (9175290)?

If there could be another problem associated with my base only boost situation, then Rico do you know anyone in Ct or nearby that might have a T5 9-3 or 900?

Tx
Slaaby Seconds is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 01-30-2005, 12:54 PM   #20
Live, eat, and sleep by TSL
 
ricot83's Avatar
 
Join Date: Jun 2004
Posts: 1,253
Send a message via AIM to ricot83 Send a message via MSN to ricot83
mike blue 9-3
wyldmansaab
um a12
bunches of people
ricot83 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:17 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright © The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.