The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Performance Modifications for the NG900 / Old 9-3 > Exhaust Smoke - My 99 9-3

Performance Modifications for the NG900 / Old 9-3 This forum contains PERFORMANCE related Q&A's for the NG900 and 9-3. This may also include suspension.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Exhaust Smoke - My 99 9-3 Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-02-2012 12:49 PM
BuHuSPG
Quote:
Originally Posted by Jaws View Post
once and the tires were screaming in second
Oops

11-02-2012 12:11 PM
Jaws Yeah, it pulls like a freaking train. I haven't hit it that hard yet but I did give it the full goose once and the tires were screaming in second
11-02-2012 12:02 PM
Saabeh Damn! Thats a quick turnaround to a stage 5 car haha! Must go like stink!
11-02-2012 11:53 AM
Jaws I finally got a JZW Stage 5 ECU, Green Giant injectors and the 3 bar map sensor installed. I pulled a real amateur hour and wired the IAC to injector #1 and vise versa. This cost me a trip to the shop but it's back and running strong! Only got a few miles now but it really runs nice!
10-09-2012 06:04 PM
NeedForSwede I'll be doing the same thing this weekend when it's time for an oil change.
10-08-2012 01:33 PM
Jaws msg sent
10-08-2012 04:58 AM
justineffingp having the exact same issue with my car, havent compression tested it yet, but hoping its the same thing. Whatd the gpopshop rebuild cost if you dont mind me asking?

I have a tdo4 at home that needs a rebuild as well, so i'm up in the air about what to do lol.
10-08-2012 04:23 AM
Jaws
Quote:
Originally Posted by NeedForSwede View Post
All smoke gone?
Roger that! Nice to be back on the road again
10-07-2012 04:08 PM
NeedForSwede All smoke gone?
10-07-2012 03:59 PM
Jaws Old


New


New


Engine


09-25-2012 11:30 AM
Jaws So my T25 is at the GPOP Shop getting rebuilt into a Big T28!

I'll be running this on lower boost (19-21 psi) until I get injectors, 3 bar map sensor and a fuel pump.

Tony
08-18-2012 07:56 AM
Jaws
Quote:
Originally Posted by NeedForSwede View Post
That's close to where my numbers are as well which makes me think it's your turbo even more.
Roger that! It did start to whine a few months ago.
08-18-2012 07:09 AM
NeedForSwede That's close to where my numbers are as well which makes me think it's your turbo even more.
08-18-2012 06:41 AM
Jaws The compression numbers are in. Done hot w/ fuse 32 removed. 110k miles on motor. Numbers look real good so maybe time for the Big T28. I’m a little undecided since the car’s a little long in the tooth but I know I won’t be happy with another car short of a CTS-V, 335, STI or M5. Need 4 doors.

1 = 205 psi
2 = 205 psi
3 = 205 psi
4 = 200 psi
08-16-2012 04:03 PM
NeedForSwede I have a feeling it's your turbo. I bet it burns right in the beginning of going WOT and then returns to normal through the rest of the RPMs.
08-14-2012 07:54 AM
Jaws Thanks - I agree, probably the turbo seals. I'm going to pull the plugs later this week, look for signs of coolant and check compression while there.
08-14-2012 06:34 AM
win_k First guess is the you're losing the seals in the turbo.

A cheap rebuild kit for the turbo is about $60, a better solution would be a rebuilt center section.

Probably the best low cost option would be a used turbo (if it's got a warranty)
08-14-2012 05:10 AM
Jaws
Exhaust Smoke - My 99 9-3

So my car started smoking a few days ago. It is releasing a blue and white smoke when hot. There is a nasty burning smell sometimes. It does not smoke at startup that I can tell. It appears that I am losing some oil and coolant via burn. No leakage to the ground. It still runs normal but maybe had some loss of boost before the smoke started. I am running on base boost now.

It smokes between shifts and when decelerating but not at idle and not when cruising. It does not smoke at WOT. It smokes when I rev it sometimes.

What say you? Iím thinking head gasket or my stock T25 turbo has failed. The head gasket was replaced 7 years ago before tuning. I have been running stage 3 at 19.5 psi for the last 2.5 years. Iíve been running it hard in the heat lately (never overheated and low speed fan works OK).

If I do a compression test and if the numbers are 180-190 psi, can I conclude that the head gasket and motor internals (pistons/rings/valves/valve seals) are good? Any other thoughts as to the cause?

Thanks,
Tony Jaworski

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 07:04 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright © The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.