The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > General NG900 / Old 9-3 Posts and Information > New Car, New questions

General NG900 / Old 9-3 Posts and Information Please post general topics pertaining to the NG900 and old 9-3.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: New Car, New questions Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-09-2009 05:47 AM
Martin42
Quote:
Originally Posted by saabhater09 View Post
Did you ever ask why the engine was replace? I'm assuming sludge problems and thus an engine seizure
The engine was replaced on comprehensive, he was sitting in 6 inches of water in a flash flood, a truck drove by and he sucked up water. Instant seize. All the insurance paperwork was provided as well as the shop bill to prove it was all done, at the time it got a new clutch and a few other things plus the newer engine, good!

I can absolutely narrow it down to this affliction. When I am driving, if I stomp on it, it will go only a certain boost. But if i press the gas, let off for a second and do it again, it takes off like a different car. Everytime, every gear. Any ideas?

Also.. My brother's scion TC was faster than my car... is that normal? Well it wasn't when I was boosting after acceleration...stopping...ACCELERATION...shift...

Any ideas?

Thanks!
08-27-2009 10:50 PM
Martin42 Alright, I'm back.
A few things. First off, what is the exact model number of the plugs i should get? Thats going to be first up. I wont go with plat if it doesnt need it for the extra money.

Next, the noise happens when im rolling slow or stopped and turn the wheel. When the front end is jacked up and i turn the wheel, nothing. So it is making noise while under tension, so perhaps the strut bearing? I will do that test tomorrow Sabeeh, just to see. I dont need an adjustable kit, i would actually prefer not to have one really. One setting is fine; stiff. what are my options besides the blistiens? Ill do some research but what kind of price point am i looking at to do the shocks all around and the springs?

Finally. What kind of gas mileage do you people return? I do probably 50/50 city and highway and I ended up wtih 350 miles to my 17.5 gallon tank. That is around a 20.8 mpg average... not what im expecting from the supposedly miserly thirst 2.0. Any ideas on that?

Plugs first, ill look for the cleaner for the MAF.

Anyone close to philly want to meet up to try the MAF and DI they know are good in thier car to mine? PLEASE!

thanks everyone.
08-25-2009 04:43 AM
saabhater09 Did you ever ask why the engine was replace? I'm assuming sludge problems and thus an engine seizure
08-24-2009 01:57 PM
nowhereman no need for the NGK platinums. If you can get them for under $20 for a set go for it otherwise not worth it as they really won't add much if anything to a car running pretty much stock.

for the MAF i have no experience with them however if you plan on replacing it anyway you might want to try cleaning it first. I know i say some spray type stuff for cleaning them at my local parts shop and from the few people i talked to it seemed it was worth the $10 for it. Might want to try that before replacing it. maybe it will fix it?

on the suspension i have heard that konis are great however the price you pay to have the adjustibility (that you may use once a year if at all) isn't worth it. You may want to look at some Bilstien HDs as everyone i know that had them loves them. as far as those tires it sounds to me like they will rub if you do any kind of drop in suspension but i could be wrong...
08-24-2009 01:54 PM
Saabeh With the hood popped, turn the wheel and see if the tops of the struts move a considerable amount. Strut mounts/bearings.

New NGK Plugs and test fit a buddy's known working DI and MAF separately.
08-24-2009 01:43 PM
soccerrplyr 02se had the tdo4
08-23-2009 10:09 PM
Martin42
New Car, New questions

Hey. I just came into being of an 00' 9-3 se after a debacle with my viggen back in April. It runs really nice and smooth, has great service records but there are a few concerns i want to clean up before i move forward and put many miles on it. Its got 101000 on it now.

First off, as soon as i took it home from the guy, it started making noise when i am turning slow or stopped, i think it might be the strut bearing on the right side? I have been toying around with the idea of getting a new suspension setup if im taking it apart to do the bearing anyway.. I know koni's are popular. My 17 inch rims have 235 tires on them so they are pretty thick.. any ideas how far i can drop it without the worry of major rubbing? I would like to fill the gap, not really into tucking. Im also on a relative budget... so for instance; would stock shocks with lower springs fit the bill just as well? Im not super knowledgeable about suspension.. i know there is lots on here about it but ive been too busy to search and im heading out where i will have very limited internet access for a week so i dont have much time to look it up.

Second off; the car can pull. I know it wants to. It already has the steering rack brace on it; it torques a little even with that. sometimes. Wide open, sometimes it pulls through the power range straight through and doesn't hesitate; sometimes its almost a little jumpy where i can feel its on the verge of letting go and pulling full throttle. As far as i know the MAF is the original.. which means im ready to replace it now and i think with the t7 thats not a bad idea.. could that be the culprit for my lack of consistent power? Where is the cheapest place to get a MAF? I also plan on putting some new NGK plugs in there.. is it overkill to run the platinums?

Im hoping those issues resolved will make this car a dream. Its in perfect shape; ill be posting some shots up when i get back from vacay. I just want to do things right, on a budget and maybe make some improvements while ive got it all apart.

Oh yeah. One more things. The engine was replaced with an 02SE with documented insurance and mechanical paperwork... what are the exact specs on this? What size turbo is it? TD04 or wishful thinking? Like it said, i was moving pretty well with it, when my power was consistent.

Thanks for the input. Ill have the pictures up soon, any help will be much appreciated!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 02:03 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.