The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only > Oil Pump Whine?? (Video Included)

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Oil Pump Whine?? (Video Included) Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-27-2017 09:40 AM
DrewP That sounds like balance shaft or timing chain to me. It didn't make that sound before the head gasket was done? When you removed the timing chain tensioner did the back chain guide pivot freely?

Stupid question, but you released the ratchet in the tensioner by removing the 13mm hex head bolt and spring from the tensioner before you put it back in, right?
07-26-2017 04:04 PM
leiframsey Update: I ran out of ideas and took the Saab to a shop to see if they could help diagnose it. They ran through some of the same list that I didn't and couldn't figure out what was causing the whine. They pulled an oil pressure test and pressures checked out as normal. Idle: Between 18-20 psi. 2500 RPMs: Between 35-40 psi.
06-12-2017 06:42 PM
leiframsey
Oil Pump Whine?? (Video Included)

I've got a '97 Saab 900 SE Turbo with 350k miles. Just replaced the head gasket on it. Now that I've got it back together there's a noticeable whine coming from the oil pump area. The whine is still there even with the serpentine belt off. (Video link: https://vimeo.com/218544188/f86017032e)

I've tried replacing oil pressure regulator and spring, dropped the oil pan and checked the pickup screen for debris (it's clean), swapped oil filters, and pulled and reset the timing chain tensioner. I've also pulled the oil pump and visually inspected (replacing the housing oring and crankshaft seal). No sign of problems.

No luck. I'm out of ideas. Timing and balance chains were replaced 1yr ago with Saab OEM chains.

Any ideas on what I should check out?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 12:46 PM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.