The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only > Transmission Banging!

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Transmission Banging! Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-26-2015 10:06 AM
chazmatic
Change ATF Fluid

Thank you. I will use the Mobil 3309. Everyone has got me scared to use the RP SYN 3309 ATF. I'll get back when it's done. 95 95 93.
02-23-2015 04:52 AM
Mike Brennan If, after you change the fluid and it still bangs and your mounts are good the valve body can be replaced while the box is still in the car.
02-20-2015 07:01 PM
chazmatic Is it in the transmission? Can it be unstuck or does it need to be replaced? Thanks again.
02-20-2015 12:29 PM
DrewP It's usually a sticky solenoid in the valve body.
02-20-2015 08:19 AM
chazmatic I know what your saying. My wife bought me a case (12 qts) of RP ATF last year. It's been in the closet. I did buy a case of Mobil 3309 off Amazon recently. I have three Saabs: 2002 95 ARC, 2004 95 Wagon and a 2006 93 AERO sedan. As I said in my first post with the 2002 banging when I put it in drive from park. I thought the RP would help. Does anybody know why it bangs. All the mounts are fine. Thanks again. 95 95 93.
02-18-2015 04:53 PM
oliversexpedition Second/Third using Toyota Type-IV, its about $6-7 (Carquest) a quart where the RP is ~$13 retail (Summit racing). In fairness to the RP rep, they claim that its a replacement for about everything, ie everything looks like a RP solution.

No need to run the car, it will drain out the plug just fine. If you want to change the filter, it will drain faster. As Drew said, fill run thru the gears, rinse, repeat. Which is also why Toyota fluid is cheaper to use.
02-18-2015 11:36 AM
DrewP The Toyota Type-IV fluid is also much cheaper...

I would not try to change it with the car running like you are planning, if something happens and the pressure pump gets a big gulp or air it could damage the pump. It's not that hard to drain it, fill, run the engine for a few mins and shift it through the gears, and then repeat.

Even the blackest fluid drains clean after the 3rd flush.

The factory literature all says to use mineral based (NON-synthetic) 3309 spec fluid, but if the newer 3309 compliant fluids use synthetic base stock they should be fine since it is tested to meet 3309...


....But the Toyota fluid is cheaper....


02-18-2015 04:09 AM
Mike Brennan Sorry, but you cannot use Syn in your Saab.
02-17-2015 06:40 PM
chazmatic
Changing ATF

I'm going to put in Royal Purple ATF SYN 3309. I'm going to remove the feeder line, put a 5 foot hose on it, put that end into a bucket, let the car run until the new fluid shows new. I will be putting in new fluid as the car is running. That way I can change all the fluid at once. I did speak to the RP rep and you can use it in my 2002, 2004 95's instead of the Mobil 3309.
02-17-2015 04:07 AM
Mike Brennan 2002's had valve body problems. They can be changed out w/o removing the transmission. However, the 1st stem is to do a 3x drain and fill with the right transmission fluid. the 02's began with the use of Mobil 3309 or Toyota Type IV I believe. Do not put in the wrong fluid. Of course I am assuming you have checked your motor mounts and they are all ok.
02-16-2015 06:45 PM
chazmatic
Transmission Banging!

I have a 2002 95 ARC Sedan, 133K When I start the car(no problems starting) and I put the shifter from park to drive or 1,2,or
L, I have to wait 2 or3 seconds before it goes into drive and it bangs like a u joint is gone but they are not. I had them checked out. I keep my foot on the brake petal when I do this. Very rarely it doesn't bang. It never bangs in reverse. When I get going it shift very smoothly like nothing is wrong. When I come to a red light it down shifts the same way. (smoothly). Would changing the fluid help or is it not the transmission at all??? Thanks again.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 07:33 PM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.