The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab New 9-5 '10+ Forum > Car Problems? New 9-5 Only > XWD Differential Problem?

Car Problems? New 9-5 Only If you're experiencing problems with your new 9-5, post your question in here.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: XWD Differential Problem? Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-17-2015 12:28 PM
cdyoung
XWD Differential Problem

I have the exact same problem with my 9-5 AWD. The differential seems to apply the brakes when you accelerate. Pull the two ABS fuses under the hood and see if the problem goes away. In all my in tenet research over the past tweo months I beleive the poroblem is with the haldex Generation IV AWD. Specifically the DEM which electronically controls the limited slip differential. I changed all the fluid a couple of years ago but am willing to change it again based on some other post. I think the unit needs to be removed and sent to a shop which fixes the same units on Volvos. Let me know what you think.
01-06-2015 04:59 PM
rafreeland Thanks. It just seems odd that I'm not getting any warning message from the electronics.
01-05-2015 05:07 AM
Turbo00 My parents have a 9-3X, same haldex AWD system as your NG9-5. They had a 'service XWD' message on their dash, and maybe, mayyybe a little hesitation from a stop/around a corner. Turned out to be a bad diff fluid pump and rear diff fluid that, according to the service writer, was 'like sludge.' The diff does seem to be the only real 'common' replacement on the systems so far.
01-04-2015 01:43 PM
rafreeland
XWD Differential Problem?

My 2010 9-5 Aero XWD has developed an odd sound and hesitation in the rear when accelerating from a stop or turning (more right than left). It goes away at speed or after driving for a while My mechanic (and I) think it's a problem with the XWD differential in the rear. Anyone familiar with problems of this sort occurring with the XWD system, and solutions?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 01:25 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.