The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only > Aero 9-5 Manual shudder when reaching red marker on turbo

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Aero 9-5 Manual shudder when reaching red marker on turbo Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-22-2014 08:34 PM
Quman12 No, the check engine light does not come on, no misfires so no check codes, only does it if I have to suddenly give it gas other wise it will get up to 90 pretty quick just need to watch the turbo needle in all gears(even in auto).
11-19-2014 04:52 PM
DrewP Is the check engine light flashing, and setting misfire or knock codes?
11-19-2014 04:13 PM
Quman12 I have the same issue. Shudders before red line but when I get off the gas its back to normal, other than that it rides smooth. Anyone know what's going on?
10-13-2013 09:22 AM
oliversexpedition How old is your DI? Check your vacuum and intercooler hoses?
10-12-2013 11:22 PM
mrdouble08
Aero 9-5 Manual shudder when reaching red marker on turbo

Hey guys,

Today my car started shuddering under load (pretty much when the turbo hits high yellow/red. It hasn't happened before and not sure what to look for.

Any tips?

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 01:05 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.