The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Car Problems? NG900 or old 9-3 Only > oil light occasionally at idle, at first drive of day

Car Problems? NG900 or old 9-3 Only If you're experiencing problems with your NG900 or 9-3, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: oil light occasionally at idle, at first drive of day Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-19-2014 11:17 AM
DC_SAAB for whatever its worth and somewhat related.. I've seen where some folks have blown the seals at the turbo and lose oil pressure. Check for leaks near the turbo. Or blown Head Gaskets as well.. I had the experience of adding more antifreeze to my car and not seeing it go anywhere on the ground.. most times my HG blew internally.. and possibly by design.

Sounds silly but got in the habit of checking the oil for any discoloration on the dip stick.. and re-torquing the head every so often after major upgrades.

The simplest recommendation you eluded to early on.. is dropping the pan and cleaning that pick-up tube screen. But use high mileage oil with viscosity that applies to older cars.
09-16-2014 05:07 AM
JohnZ Thanks for the feedback. I forgot to say that I installed a new filter with the oil gauge. As I may be pulling it off again shortly, I bought a cheap one from O'Reilley.
09-15-2014 05:36 PM
DrewP If you get 20 or so psi at the adapter at idle I'd try replacing your oil pressure switch and drop the pan and clean the screen and pressure bypass to be sure.

The stock sender should turn the light on at about 6 psi. Your sender might just be coming on too early.
09-15-2014 04:44 PM
bseries93 I know it sounds stupid but my brothers 99 9-3 SE and my friends Viggen had the same issue when they used Mobil 1. Once I told them to switch and try Rottella T6 in the cars the problem with oil light coming on low revolutions went away.
09-15-2014 04:43 PM
Tboy Is only trust a gauge installed in the factory location (on the back of the block). That's how saab checks them, and that's how I do it. You can find electric gauges that have a sender that will run both the gauge and the dummy light, or eliminate the dummy light since you now have a gauge.

If your motor is still quiet, I'd drop the pan ASAP and investigate/clean. Anything else is speculation.
09-15-2014 04:35 PM
JohnZ
oil light occasionally at idle, at first drive of day

I've had an oil light coming on for a few seconds, usually during the
first drive of the day in warm, not hot, weather, nearly warmed up,
after moderate revs and then moderately hard braking, at just above
idle, as it's dropping to idle. . The oil sump has a few carbon
granules (probing/scooping with a long popsicle stick), but I mean a
few....wouldn't say it is sludged up. I added an oil pressure gauge
via an oil filter sandwich adapter and the pressure there seems fine, if
not high.....that is, after warming up, ~22 psi at idle (1000 rpm), and
pins the gauge at 80 psi at about 3500 rpm. Cold, it is much higher of
course....40 psi at idle and pins the gauge at about 2000 rpm. My
question is, how reliable is the oil pressure reading taken at the
sandwich adapter (before the filter, not after as would be
preferred)....reliable enough to say oil pressure is fine? Details:.
running Mobil1 0-40w, 1999 9-3 SE with B204L engine, 234k. I'm
changing oil at 5000k but I don't know the history prior to the 3 years
I've owned it. Engine sounds fine, smooth & quiet, no tappet noise.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 11:50 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.