The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only > Turbo gauge will not go past white.

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Turbo gauge will not go past white. Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-13-2013 04:20 PM
bacdy Would problems with this module cause my boost issues?
12-13-2013 02:10 PM
oliversexpedition I would see if you can swap a DI from another car, see if you can borrow one?
12-13-2013 12:46 PM
g96nt https://www.saablink.net/forum/genera...tion/77241.htm

SaabCentral Forums - OBD II code P0455 ?
12-13-2013 12:10 PM
bacdy The codes that got pulled are
p1312
p1334
p0455
p0340
12-13-2013 10:29 AM
bacdy I'm still have not got the code pulled again quite yet, so I can't give the exact error. As for the bolt mod, it does not seem to be helping much at all. It gets closer to yellow, but still will not go into it. There is no smoke and no excessive noise coming from the exhaust.
12-13-2013 06:55 AM
jssaab There is no code for CPS. ( crank position sensor)What is the code you pulled ( Saab codes are different report them here we will tell you what you have wrong)

You are probably reading CAM position sensor, there are none on T7, it usually indicates a bad DI ( Direct Ignition Cassette). You should also make sure you are running only the recommended NGK plugs, others can destroy your DI

For your, boost, you need to try the bolt mod, pull the top hoe off the BCV and plug it with a bolt or something
12-12-2013 09:51 PM
bacdy So a check engine light had come on, and pulling the code it was for the CPS. Would this cause the engine to limit boost to the point where I wouldn't have any?
12-12-2013 05:45 PM
bacdy I've already been fiddling with it. The arm is still securely fastened and moves fine as far as I can tell.
12-12-2013 05:13 PM
DrewP The wastegate actuator may just not be connected to the wastegate, you can see it from underneath pretty easily, if you don't know what you're looking for from the top it might be tricky to figure out if it's connected correctly or not.
12-12-2013 02:39 PM
bacdy
Turbo gauge will not go past white.

Hi, I recently purchased a 2003 9-5 and noticed I seem to be getting no boost whatsoever. The gauge reads as if it is spooling and building, but it will never reach into the yellow, which if I have researched correctly, should be the start of boost. I can hear the turbo spooling up fine it sounds like.

I've gone over all of the lines under the hood I could get to, and there doesnt seem to be any leaks/cracks anywhere. I don't have any CEL codes being thrown, and the vehicle runs fine besides this.

It would not be such a big deal if it were not for the fact that if I floor it it seems like all it wants to do is rev and not go anywhere, which makes passing on the Interstate a pain.

I have tried unplugging the APC(?) which should get me to base boost, but does nothing? I am also not in limp mode.

Thanks for any help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 04:58 PM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.