The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab NG900 '94-'98 and 9-3 '99-'02 Forum > Performance Modifications for the NG900 / Old 9-3 > Jak Stoll exhaust from 900 for my 9-3?

Performance Modifications for the NG900 / Old 9-3 This forum contains PERFORMANCE related Q&A's for the NG900 and 9-3. This may also include suspension.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Jak Stoll exhaust from 900 for my 9-3? Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-29-2012 10:01 AM
mike saunders
Quote:
Originally Posted by T22A80 View Post
Oil? From where? You think the turbo leaked oil into the exhaust?
It's not uncommon and it's certainly possible. Blue smoke on startup is a telltale sign of a failing turbo, or seals needing replacement.

If the PO blew a turbo, it's definitely a possibility. Run it for a week -- especially longer distances at highway speeds -- to see if it clears itself up by burning out of the exhaust system.

If it doesn't go away, and you're still getting the blue smoke at startup, then go to Plan B...
04-29-2012 08:38 AM
T22A80 Oil? From where? You think the turbo leaked oil into the exhaust?
04-29-2012 05:53 AM
mike saunders Was there oil in the DP and cat? I'm betting there was....
04-29-2012 04:25 AM
T22A80 When I started it this morning I saw a lot of smoke. It looked darker than just cold weather smoke. I noticed last night it smelled pretty rich but seemed to run fine. I'm hoping nothing serious is going on.
04-28-2012 06:09 PM
srp Glad to hear it! Now get it tuned and really enjoy the fun.
04-28-2012 06:01 PM
T22A80 I got the downpipe and exhaust installed. Sounds great at idle and isn't annoying when you really get on it. I'm pretty happy. Drove about 10 miles and no CEL.... YET! Lets hope it stays that way! haha

Turbo spools up a lot faster and the MPG on the SID even went up .1 in the short distance I was driving. And I was driving it hard. I'd love to see if it goes up even more.
04-25-2012 04:51 AM
T22A80 Well luckily they are both Manuals so hopefully this wont be an issue.
04-24-2012 12:21 PM
mike saunders
Quote:
Originally Posted by srp View Post
I believe it needs to be the same type of transmission as well, unless JAK made a universal fit downpipe for manual and automatic cars.
Good point....

What do you think the odds would be that it's universal?
04-24-2012 12:13 PM
srp I believe it needs to be the same type of transmission as well, unless JAK made a universal fit downpipe for manual and automatic cars.
04-24-2012 12:06 PM
mike saunders A 95 is OBD I, and doesn't use the downstream O2 sensor.
96 and older is OBD II and requires the sensor.

If the bung is there, just screw your existing sensor into it.
04-24-2012 11:57 AM
T22A80
Jak Stoll exhaust from 900 for my 9-3?

Hey guys,

I have an opportunity to buy a Jak Stoll complete exhaust from someone local that includes the 3” DP, race cat and 2 mufflers. The doaner car is a 95 900 but the exhaust was bought in 08. My car is a 02 9-3 SE. My questions are will this fit up ok? I emailed Jak and he said I might have to modify the tailpipe section and also move the rear 02 sensor by unclipping the wire from above the bell housing and dropping it behind the intake manifold. Has anyone tried to do something like this? I’d like to get as much info as possible before deciding to do this. Some questions I have are will this give me any issues since this was in a T5 car and mine is a T7? It sounds like his current setup doesn’t have the o2 sensor after the cat. It has the bung on it but no sensor hooked up. Would this cause any problems? Can a tune fix this?
Any help would be appreciated!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 05:23 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright © The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.