The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only > '99 9-5 manual transmission cruise control not working

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: '99 9-5 manual transmission cruise control not working Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-28-2017 05:37 PM
DrewP Check for continuity at both pedal switches, there is one on the brake pedal and clutch pedal. These are the most common reason it won't work. If the switches are Ok, then check that you have voltave across the two wires going to the switches with the switch un-plugged and the ignition turned to ON. You should have +5 or +12v across the two wires for the switches (I forget which).

It's also possible for them to be misadjusted on the brackets so the switch is being tripped when you're not actually depressing the pedal.

If that's all ok it may be tricky to diagnose, but report back.

And welcome!
07-28-2017 04:31 PM
Boitet
'99 9-5 manual transmission cruise control not working

So I decided it's finally I'm to figure out why my cruise control isn't working, but I don't really know what all to check. The fuse is good, and the pedal sensor doesn't appear to be PHYSICALLY damaged, but I don't know if it could still fail internally. Should I start with replacing the clutch switch, or with something else?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 08:01 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.