The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > General 9-5 Posts and Information > Intermittent Check Engine Light Saab 9-5 Aero Sedan 2.3L Turbo

General 9-5 Posts and Information Please post general topics pertaining to the 9-5.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Intermittent Check Engine Light Saab 9-5 Aero Sedan 2.3L Turbo Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-30-2016 07:32 AM
rezmia
same problem from Sweden"

Hi
I experiencing same problem as you described about saab 9-5 check engine keeps coming back and going off.
Did you find a solution to the problem. could you please share it with me?

Kind Regards
Rezz



Quote:
Originally Posted by meswalk View Post
Hello members,
I have had a strange problem with my Saab for the past three years. The check engine keeps coming back and going off. Specifically, it often comes back (if it has disappeared) when I fill up gas. I got the following codes using an OBD II reader P1312 P1314 P0455 P0340. I was told the gas cap and the ignition module cassette needed replacement. I changed the ignition module twice along with spark plugs to no avail. I have also changed the gas cap (albeit with a non-OEM one). I was wondering what could still be causing the CEL. More importantly, I am quite puzzled as to why it keeps switching off and coming back on. Any inputs will be highly appreciated.
05-02-2011 08:45 PM
meswalk Sorry forgot to mention the car is a 2003 model. I am the second owner and the previous owner also has had similar complaints since 2007. He did not change the DI, apparently never experienced any engine problems, but did report the same CEL behavior.

I had taken it to an independent mechanic for a second opinion and he said the PVC hoses are fine and the dealer was just trying to rip me off. In any cases, can spongy hoses lead to CEL getting triggered?

Thanks again for your time and effort.
05-02-2011 06:08 PM
jssaab
Quote:
Originally Posted by meswalk View Post
Thank you, jssaab for the incredibly prompt response.
The DI was replaced with a new one. I also might mention the following things the dealer said at the last inspection. I am not sure if they are relevant (the check engine light was not on at the time of inspection, so they could not test the codes then).
1) Cylinder head gasket is leaking
2) Crank vent hoses spongy

I am not sure how to check for the leaks you mention, but I will do some digging around.

The change of behavior with refueling is erratic. Some times the light comes on after a refill, sometimes nothing happens. I would monitor it more closely now that you mention a possible gas tank leak. Should I replace the gas cap with an OEM one?
What year car? Most shops can test the cap for you, but sure try a differnet cap.

You need a new PCV systme version 6, if the hoses are spongy. It could also mean your car is suffering from sludge, very common on these cars but not so much on aero models if they have had the required syntheitc oil and 5 k max oil changes.

If you have an early model car you may just need to re-torque ( or repalce) the head bolts ( and the PVC also reduces crankcase pressure so many leaks will go away)

Did you buy an OEM DI ( there are only junk chinese aftermarket ones that actually don;t work the way they are suppsed to, I think they just wired the coils up with no electronics
05-02-2011 08:07 AM
meswalk Thank you, jssaab for the incredibly prompt response.
The DI was replaced with a new one. I also might mention the following things the dealer said at the last inspection. I am not sure if they are relevant (the check engine light was not on at the time of inspection, so they could not test the codes then).
1) Cylinder head gasket is leaking
2) Crank vent hoses spongy

I am not sure how to check for the leaks you mention, but I will do some digging around.

The change of behavior with refueling is erratic. Some times the light comes on after a refill, sometimes nothing happens. I would monitor it more closely now that you mention a possible gas tank leak. Should I replace the gas cap with an OEM one?
05-02-2011 07:48 AM
jssaab P0455 is evap leak, check your evap hoses ( gas cap too) check the charcoal caniter and the vavle there to make sure it it working. Evap codes will go way of the leak is no longer detected ( like at a faulty vavle that starts to work or is only faulty in one position. Can also be from a leak in the gas tank, if you fill up does it go away and only when you have less fuel does it come back?

1312 0340 and 1314 are all DI, did you get a new one? THey will not case and CEL all the time but wil show up if you get a cel for other reasons.
05-02-2011 07:43 AM
meswalk
Intermittent Check Engine Light Saab 9-5 Aero Sedan 2.3L Turbo

Hello members,
I have had a strange problem with my Saab for the past three years. The check engine keeps coming back and going off. Specifically, it often comes back (if it has disappeared) when I fill up gas. I got the following codes using an OBD II reader P1312 P1314 P0455 P0340. I was told the gas cap and the ignition module cassette needed replacement. I changed the ignition module twice along with spark plugs to no avail. I have also changed the gas cap (albeit with a non-OEM one). I was wondering what could still be causing the CEL. More importantly, I am quite puzzled as to why it keeps switching off and coming back on. Any inputs will be highly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 02:34 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.