The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab New 9-3 '03+ Forum > General New 9-3 Posts and Information > 2003 saab 9-3 arc 2.0t radiator fan not running.

General New 9-3 Posts and Information Please post general information pertaining to the new 9-3.

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: 2003 saab 9-3 arc 2.0t radiator fan not running. Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-21-2015 04:45 PM
yoboyd06
2003 saab 9-3 arc 2.0t radiator fan not running.

Hello good people of Saablink, I hope someone can help me before I just give up on my saab and start riding my bike to school. My saab recently overheated , turned out to be the fan not turning on. I thought it was the relay (the box on top of the fan) so I changed and it did not help. I changed both fans and nothing. I thought maybe it was the temperature sensor So I changed that and when I turned on the car the fans (both of them) turned on imediately but the car was cold. I realized shortly after that I forgot the plug in the temp sensor. after I plugged it in I started the car back up and the fans did not turn on. I drove the car for about 30 minutes in the city and once again it overheated, fans weren't kicking on. To get around it I just unplugged the temp sensor so that I could drive around while I figured it out but I dont know what else it could be. I don't want to leave it like that because I don't know if my car is overheating or not plus I'm sure it can somehow affect something else. Any help would be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 01:57 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.