The Saab Link Forums - Reply to Topic

Go Back   The Saab Link Forums > Saab 9-5 '98-'09 Forum > Car Problems? 9-5 Only > Saab 9-5 Problem Starting - Need Help

Car Problems? 9-5 Only If you're experiencing problems with your 9-5, post your question in here. CEL Code or GTFO!

SaabLink.net is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Thread: Saab 9-5 Problem Starting - Need Help Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Saab Link Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Vehicle Info.
Enter your vehicle information (year, model, mods)
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-17-2014 08:10 PM
Saabeh Well, a DIC that throws a code is on its way out unfortunately. But the starting then dying sounds like a fuel pump getting weak as well.
12-17-2014 03:58 PM
saabambro
Saab 9-5 Problem Starting - Need Help

Car History

I have a 2001 Saab 9-5 and it has been giving me problems lately. The first problem was when I was driving the car completely died on me, I figured out that problem to be the DIC (Direct Ignition Coil Module) I managed to get one used from a dealership for a great price, the only problem was that the used module was going to give me an "engine light on" which doesnt matter to me since I already have a valid e test.

Current Problem

I left my house in the morning and the car didnt quite start first try, so I tried again and it started up fine just felt a bit shacky when backing out the car, I drove where I had to be which was around a 45 minute drive then parked the car, the next day when I went to go start it, it didnt start. I would turn the key and it would boot up but immediately die out, after trying this numerous times I put the car in neutral to start it, and immediately rev the engine to around 2000 rpm and kept it there for the engine to heat up, after letting it run for a bit I put it in reverse to back out and it died. So I tried again putting it in neutral but this time I let the engine heat up for around 15 more minutes, and the car seemed to work fine, just felt a bit choppy at begining but once I was on the road out of the parking lot it drove fine.

Any ideas on this issue? it seems to start completely fine now if the car was warmed up and if I just finished going for a long drive.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -8. The time now is 06:49 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All content is copyright The Saab Link and it's original authors.


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.